OSMC Release Candidate 3 lands

Originally published at: OSMC Release Candidate 3 lands - OSMC
Hi everyone, We’re happy to announce that OSMC Release Candidate Three is now here. This issue squashes a few bugs and refines OSMC to a state that we would now consider stable. We’ve seen that some of you are eager for OSMC to become ‘final’ and even think it’s holding us back. We understand that…


Since RC1 would you recommend update system or total new install ?

great, thanks!

will update via OSMC update system tomorrow!


We’ve been working hard to ensure that upgrades are easy.

Provided you’re on Release Candidate 1 or later, an upgrade is more than fine. We’ve worked hard to make sure updates are handled better than Raspbmc. If you want the update now rather than waiting for a notification, just go to My OSMC -> Updater -> Manual Controls and select Check for Updates now.

If you have any problems, please start a new thread (this one’s bound to get a little crowded).


Update to RC3 today appears to have gone off flawlessly. Thanks for fixing the remote repeat rate!

Is there 3D support ?

Which platform?



Should be some preliminary 3D SBS support already. We will add 3D modesetting and interlaced modes in June.


ifupdown works only for lo interface? Im using wlan

Please start a new thread with some logs


About Ocelot: Does/will it support HTML5 video playback in 1080p? I can imagine that the pi1 is too weak for such task but maybe it would work on a hummingboard/cubox-i…if there will be a OSMC release for i.mx6 devices… :smirk:

is this missing a zero or is the comma in the wrong place? hopefully the former! looking forward to release :slight_smile:

Why so many updates today? I think three times now I’ve been informed that an OSMC update available and that OSMC needs to quit Kodi to install the update. After each one it still says RC 3 - 0.9.9.

This on both an RPi and a Vero.

Is this the way it’s supposed to be?

A couple of minor updates have been pushed since RC3, however if you see new updates every time you check there may be a problem with an update not installing. If so please use the log uploader to upload at a minimum apt logs, osmc package versions and system journal.

Thanks. I just tried a manual update and was informed that there was nothing to install so I guess I’m good.

I should be stupid… You have a new function in “My OSMC” to backup and restore. I finally found it in the “Update” menu. But how do you configure the backup directory ?
When you try “Run Backup of settings now”, there is a message “Location for backup not provided. Set the folder backup in MyOSMC”. Can’t find where to set it up.

I answer to myself: Go in Backup menu, check “tarball” (or something like that) and define the path for backup. Then, you’re able to do manual backup

Hi, the backup option is not working properly at the moment but will be fixed shortly, probably by tomorrow. Another change that will be made is the tarball switch is being removed so that the settings such as backup path are always visible.

ARGH !!! Damned !!!
I’ve plan to migrate my raspBMC/PIB+ to OSMC. And I’ve already a OSMC/PI2 wworking fine.

So what are the problems with backup ?