OSMC Remote stopped working

I bought an OSMC remote a few years ago, and was using it on my RPi 3 with OSMC. A while ago though, it stopped working, and I tried the following:

  • Reinstalling OSMC
  • Pairing the remote and dongle
  • Testing on Windows (didn’t work)
  • Replacing the battery

On Windows and Linux, the USB dongle is correctly picked up, but even after pairing it, nothing works. The pairing works successfully, the light goes solid until I plug in the dongle, and then it does 3 brief flashes, and when pressing buttons, the blue light flashes fairly quickly, making me assume the issue lies in the dongle. Ordering a replacement isn’t an option as it is no longer available anywhere in country.


If you upload some logs it would be useful as we can then see if the dongle is detected properly. You say it’s detected – but the logs should also show signs of an issue; and we can also confirm the correct dongle is being used.

We are working on solutions for South Africa from early 2023.


Hi Sam, thanks for your response, and I’m glad to hear you’re looking at getting it back to South Africa. What logs should I upload exactly?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Hi! Thanks so much for your help. I have done that, here is the link:

Steps I followed were:

  1. Fresh install of OSMC on my RPi3B+
  2. Connect everything, boot, check remote (didn’t work), go through initial setup using Kore
  3. Enable debug logging as described above
  4. Reboot
  5. Reboot again
  6. Check remote (dongle was left plugged in the whole time)
  7. Try pairing the remote (unplug dongle, hold home+OK on the remote until blue light comes on, plug dongle back in) pairing was successful, blue light on remote flashed 3 times
  8. Try using remote again (still not working)
  9. Upload logs

Thanks for your assistance!

Is there anything in the logs that would suggest an issue? I tried looking through them but I’m not 100% sure what I’m looking for.

So, you followed Pairing the Original Black OSMC RF Remote Control with a Pi/Vero2/4k/4k+.

Just to be sure: Connected with Windows 10 and doing the notepad test, the keys Home, OK, Up, Down, Left and Right do not show any effect?
If yes, as long as you can rule out strong interference, this HW combination (dongle + remote controller) looks defective.

Hi! Yes, I followed that guide to the letter. It also doesn’t work at all in Notepad on Windows, so I think it might be defective as I feared.

Edit: Interference also shouldn’t be an issue, as there isn’t really any other RF device nearby I’m aware of, and the pairing succeeds perfectly, and the remote never seems to show any kind of connection issue

When you press a button on the remote do you see a short flash of the blue light or a long one?

A short flash, a lot less than a second

The receiver may be problematic. I’d suggest emailing support@osmc.tv so we can check what can be done