OSMC Samba shares not accessible in windows 10

I am aware of the SMBv1 not supported issue with latest windows. I tried many workarounds from different posts to fix this issue with no luck. What even I tried I was unable to access using \\sharename or mount using net use command or map network drive using gui. Please help

Here is my OSMC version, smb.conf

~$ cat /etc/os-release
PRETTY_NAME=“Open Source Media Center”
VERSION=“July 2018”

$ testparm
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The “syslog” option is deprecated
Processing section “[seagate2tb]”
Loaded services file OK.

Press enter to see a dump of your service definitions

Global parameters

log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
panic action = /usr/share/samba/panic-action %d
usershare allow guests = Yes
client max protocol = SMB3
client min protocol = SMB2
server min protocol = SMB2
map to guest = Bad User
obey pam restrictions = Yes
pam password change = Yes
passwd chat = Enter\snew\s\spassword:* %n\n Retype\snew\s\spassword:* %n\n password\supdated\ssuccessfully .
passwd program = /usr/bin/passwd %u
server role = standalone server
unix password sync = Yes
dns proxy = No
idmap config * : backend = tdb
create mask = 0700
directory mask = 0700
valid users = %S

comment = seagate2tb
path = /media/seagate2tb
browseable = No
read only = No
valid users = osmc

$ ls -l /media/
total 45
-rw-r–r-- 1 root root 232 Nov 21 2017 README
drwxrwxrwx 6 osmc osmc 16384 Jan 1 1970 RECOVERY
drwxrwxrwx 5 root root 1024 Oct 29 22:06 SETTINGS
drwxrwxrwx 1 osmc osmc 24576 Oct 29 22:58 seagate2tb

A William

This is a very similar post from just yesterday.

1 Like