OSMC Skin Bug - "Show empty TV shows" disabled setting ignored upon initial node entry

#1

I’ve come across what appears to be a minor bug with how the default OSMC skin handles the “Show empty TV shows” setting when it’s disabled. When you first enter the TV node of the library from the main menu, OSMC always displays all of the empty series in addition to series with episodes, regardless of the status of the setting. The shows are correctly hidden after you take any action within the TV library node (e.g., entering the node for a show and backing out, forcing a refresh the library, etc.), but they always show back up when you first enter the TV node from the main menu.

I confirmed that the setting behaves normally in the generic Estuary skin, so it doesn’t appear to be an issue with how the OSMC builds of Kodi are handling the setting, just the OSMC skin itself.

#2

Ping @Chillbo

#6

We’ll need debug logs.

Depending on the used skin you have to set the settings-level to standard or higher:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

OSMC skin screenshot:

#7

I’ll pull the logs when I get a chance later this weekend, but just for a quick sanity check on my end: Can you not replicate this bug on your install (i.e., is this issue somehow specific to my setup)? I didn’t upload logs with the initial post because I assumed this bug was universal and reproducible in 10 seconds on any OSMC install, but if the glitch isn’t universal, I’ll poke through my configuration a bit more first to see if I can narrow down what’s causing it to crop up before having the skin maintainers try to chase it down.

#8

This is a known bug. 2 of 3 threads has been written about this problem ( I have also provided logs)
Since no solution had been provided I switched to the Estuary skin for now.
I will follow this thread for if it brings a solution.

#9

Wow, total search failure on my part there; sorry for cluttering up the forum. I searched for “Hide empty TV” before posting this and didn’t find anything, but halfway through the post, I checked to see exactly what the actual setting was called to be more accurate with my title and realized that it was phrased as “Show empty TV…” instead. I should have re-run searches before finishing my post.

I’m definitely just running into the same issue described in Disabled "Show empty TV shows" not working correctly. I’ll go back to using Estuary for the time being, since that runs fine. I may try to back-port the hide-art-on-unwatched feature, since that’s the one piece I’ll really miss from the OSMC skin.

#10

This is part of Kodi v18 now, so no need for skins to have this setting in the future…

Re. the issue discussed here: Strangely, I couldn’t reproduce the issue until today. I’ll have another look when there’s time. Maybe it’s quite obvious what the difference between Estuary and our skin is.
As there were no more reports of this for some time, I thought it to have disappeared for some reason. Will check again :+1:t2:

#11

Just checked this again on my v18 test setup: deleted all episodes of a series, disabled “Show empty TV shows…” and it was gone. Restarted mediacenter: still gone. It never shows up here.
When enabling “Show empty TV shows…” the empty TV show shows up properly.

Maybe it’s v18, but I can’t reproduce it here. Is anyone else here using v18 as well?

#12

Awesome; one more thing to look forward to when the Leia builds go to general release.

It occurred to me that, since the only time the error triggered was when you first enter the library node from the main menu, the issue was likely related to something about the main menu link configurations. So, for kicks, I downloaded another skin that relies on the same skin shortcuts builder (in this case, Estuary Mod) and loaded it up. Sure enough, it suffered from the exact same bug.

That was enough information for me to quickly track the issue down: It turns out, when the interface accesses a view via a generic library link (e.g., library://video/movies/titles.xml/), it doesn’t apply the default video filters. You have to access via a video link instead (e.g., videodb://movies/titles/) to trigger the filter rules. It’s not a bug with your skin at all, just an issue with how the skin shortcut builder constructs its menu links. I manually swapped the ActivateWindow link to the videodb target, let the skin rebuild the menu, and all is now well.

For anyone else that wants to quickly rectify the issue, you can just put the following in for your TV menu link code: ActivateWindow(Videos,videodb://tvshows/titles/,return)

EDIT: Apparently I was taking the difficult way around. You can just select Common > TV Shows from the menu builder shortcut options, no need to manually enter any code. The Common shortcuts use the proper videodb links; it’s only the [...] Library shortcut options that do not.

All of my tests were on Krypton, so it’s definitely possible they corrected the library URIs to apply the same filters as videodb URIs in Leia (or perhaps the menu builder is doing something entirely different for Leia; I haven’t been following development to know what all has changed).

#13

Thanks for these information! I’ll check again which default values we’re using with the skinshortcuts script to build our main menu. But if it’s fixed with v18 (I’d be thankful, if someone could confirm this - best someone who knows the issue), I’m not sure whether we need to dig into fixing it for our v17 skin at this point… After all, v18 is not far off.

#14

@leurb: Have you by any chance tested on v18 whether you experience the same issue there? I haven’t had the time lately to be swapping builds, and I don’t know exactly what level of stability the latest v18 test builds are functioning at, so I haven’t experimented with them at all.

#15

Using v18 here at the moment and there haven’t been issues yet. But it might depend on what you’re doing with your Vero. Using it mostly only as a media player for movies from my NAS. No special, other use cases here.

#16

I have not tried V18 yet. I am expering the bug only on my Vero 4K and that is my main device. No problems on my Vero 1 and my RPI, I think something with timing.
My goal is to upgrade the Vero 4K to V18 when it is stable.

#17

So I upgraded to V18 and there was no difference.
Empty TV shows are still there with the Osmc skin.
With the default Estuary skin there is no problem and works as designed.

Anyone else has the same problemen with Osmc under V18?

Tia
Leon

#18

Did you try the fix from my post earlier in this thread on January 6th talking about a resolution? At least in my case, I found you just needed to update the skin shortcut menu link for the TV shows library:

1 Like
#19

@Alamei you are right, the fix you mentioned earlier did fix this bug. I missed it.
Thanks

Leurb

1 Like