OSMC – Transmission configuration (write to a router connected HDD) [help]

Hi all, firstly!
Last week I’ve bought a Raspberry Pi, and I’ve successfully installed OSMC. My “hardware” configuration is the following:

  • Raspberry Pi (with OSMC) connected with tv, Ethernet connection to LAN;
  • Hard Disk (1TB) connected via USB to my router (Netgear DGN2200);

From Kodi i see all contents of my Hard Disk, no problems at all.

My (maybe unique) problem is related to Transmission. I’ve installed it as add-on (from internal repo), and i can successfully manage it from remote (Remote Transmission, from smartphone). The only thing that I want to do is change the directory where my downloads are addressed: my goal is reach (obviously) the hard disk connected to the router (a specific folder: I will move completed download manually).

I’ve tried to change the directory from the WebUI, but few second after torrent download starts, I receive an error (permission denied).

Checked online for some guides: tried to log transmission via ssh (putty, I’m totally noob in this), but I got an error when I try to install transmission (maybe is due to the fact that Transmission is already installed via add-on?), so I can’t launch the editor to control my permissions.

During tests, Transmission has successfully downloaded a torrent on the sd (was a test, of course), so the problem is only related to the communication from Transmission to the hard disk.

I’m totally noob in the procedures, so maybe I’ve committed basic errors…that’s why I decided to write here.

ok, first you need to know:

  • user transmission daemon is launched (for example debian-transmission etc.)
    to retrieve such info run:
    ps axo user:20,pid,command | grep transmission
    first column show username, second pid and third is command.
    Find command /usr/bin/transmission-deamon… and get username from 1st col.

now find where your drive is mounted.
mount

I have something like this:
/dev/mapper/secretHDD on /media/secretHDD type ext4 (rw,relatime,data=ordered)

you probably would have something like:
/dev/sdX /...

don’t know where would be mount point so I assume that:

  • download folder - /media/secretHDD/transmission
  • user: debian-transmission

Run commands:
mkdir /media/secretHDD/transmission
chown -R debian-transmission:debian-transmission /media/secretHDD/transmission
chmod -R og+r /media/secretHDD/transmission

Thank You pszafer, also if I’m not sure to have understood :slight_smile:
I’m working now, I will try later to implement your suggestions.

Anyway…concerning your solution…u told me to verify if transmission-daemon is launched, then where is the current download folder (sdX). The second part of the explanation is less clear. When you say:

don’t know where would be mount point so I assume that:

  • download folder - /media/secretHDD/transmission

I suppose you mean the path of the folder on my hard disk: in this case I suppose I’ve to write something like:

Mkdir \IPADDRESS\HD\Download

(where IPADDRESS is the IP of my router, HD is the name of the Hard Disk, Download is the folder where I want to address my downloads).

I really need a step by step help, cause I really don’t know how to proceed in this environment :frowning:

ok, I’ll try to be more clear :smile:
I assume you working on windows.

Download Putty from here: http://the.earth.li/~sgtatham/putty/latest/x86/putty.exe and start it

And now you need to know IP of OSMC. Write it in hostname field and click connect.
Your username is: osmc
Your password is: osmc

Now you have shell screen and run those commands I wrote before.

  • retrieve username of process transmission (in my case username is ‘debian-transmission’)
  • retrieve mount point of your hard drive - this is location where drive is mounted (in windows locations are D,E drive letters, in linux it could be any place/file/folder)
  • create directory
  • give permission for transmission to write in this directory

Ahaha yea, I’m a noob…I’m quite surprised to have “only” the transmission problem, as Kodi and its addons work like a charm!

I’ve already downloaded putty and entered the omsc/omsc. Is there where i was lost :smiley:

When you say “retrieve mount point of your hard drive - this is location where drive is mounted” I cannot understand. Cause (for me, but surely I’m wrong) the hard disk is connected to the router, and it has its own “path” (\IP\Folder\Subfolder), so the part “mount” is totally new for me.

But when I type “mount”, will I see the current download folder (so the SD) or the hard disk? I know it is simple to try and get the answer, but i’m far from home and really curious :smile:

I’ve just talked with a colleague.
For him, the main problem is that the hard disk is not mounted. For him, the first step is mount the HD, so that it will be possible to create the directory. Always for him (he has been rather vague…), this could be done through samba, but lunch was more important that other details…

Maybe you sayd the same things hahaha

Sorry, I’ve misread that HDD is connected to router.
You need to mount smb share into your osmc.

Add to file:

$ nano /etc/fstab
//IPADDRESS/sharename /mnt/yourcreatedDir cifs noauto,username=user,password=pass,file_mode=0777,dir_mode=0777 0 0

Something like this.

“Add to file”…you mean to write ONLY the last command, or also it?

I have a similar situation. I am not sure if I should be posting in someone else’s thread but I havent found answers to my situation. Please let me know if its not allowed.
This is my thread: OSMC crashes on playing audio over network

OP, are you able to play audio files on osmc from the router.

My configuration is:
Raspberry Pi 2 running OSMC (ethernet to router)
USB drive connected to router (WD N750)/testing with USB flash drive before setting up a complete external HDD media hub.
I am able to access the video files on the same drive in the router, as soon as I play audio files OSMC crashes and restarts.
Everything(audio and video files) is accessible via other devices in my network.

For your situation, you might want to download the files in your computer first and then copy them to your HDD connected to your router. I tried to download files directly to the USB connected to router and it kept on disconnecting and many times I ended up with half of the files. I was trying the transmission client on mac though, not running directly from OSMC.

you need to add link “//IPADDRESS”… to file /etc/fstab and nano is text editor :smile: