OSMC update to 20.3.16-Nexus

The development branch is always merged in to staging when an update is released


Youtube’s Kodi addon issues with av1 codec videos is known and the only fix is to disable that codec in settings, then every video will work fine.

I can confirm that everything is working fine (again) after applying the above update. OSMC running Kodi 20.3 (2023.12-1 Kernel 4.9.269-42-osmc)

I say (again) because it fixed the problem listed here as well: No more UPNP client after December Vero V update - #54 by Chillbo


This doesn’t need to be done on Vero V where AV1 is supported


I also noticed more problems with buffering when using the youtube plugin on the Vero V compared to the 4K unit. And I think that this is the problem with the current version of the youtube plugin.

However, there’s a fix in the latest beta which you can try if you can’t wait for the next stable release. I’ll probably install this version later this weekend.

EDIT: the latest beta didn’t resolve the problem but disabling AV1 (for now) does help.

I assume this was on Vero 4K rather than Vero V which does support AV1

This happens on the Vero V but it has nothing to do with it’s native AV1 support. It’s just a bug in the current version of the YouTube addon.

As soon as this is fixed I’ll re-enable support for AV1 asap.

Yup can confirm it’s a youtube addon’s issue (or better, an InputStream.Adaptive one) and disabling either h264 or av1 solves the issue.

5 posts were split to a new topic: Distorted Playback after recent update

Just thought I’d drop a note that the 20.3 update in the dev repo appears to fix some audio/video sync issues I’ve been having recently. I had been noticing since the last update that the audio seemed be getting badly out of sync with tvheadend (pvr.hts), and streaming addons (paramount+ at least). Audio had been getting way ahead of the video. (never seen any issues with regular media, just streaming and hts) I had to frequently pause and resume to allow the video to catch up. I swtiched to the dev repo last night, and updated to the latest build, and the issue seemed to go away.

I’m glad to hear you’ve experienced some improvements. We’re also working on some other synchronisation issues and these improvements should be ready shortly