OSMC with PCTV 292e

So @sam_nazarko, from the error ouput, is it a thing can be handled with a bit of guidance from you

I mistakenly thought they both run the same earlier but sam advised they run different kernels I’m on a vero so I’m on 3.14 but rpi2 is 3.18 so should already be supported :-S as the stick is supposedly supported from 3.16 I think

Support just refers to in/out of tree.

It may be in the 3.18.y tree but it will still need firmware and enabing in the kernel configuration.

I doubt 3.14 is a show-stopper for this device.


@sam_nazarko, can you be more specific about driver been in 3.18, because that’s the output of my uname -r. And how do i go about enabling it in the kernel config. I already downloaded the firmware and placed it in /lib/firmware/. So its just the enabling i think might be the problem now

@phate1, not sure what i did loolll. But i used the DKMS to update the header, though the build from the link you listed above failed. But right now i can now see my device, so i guess its just a simple configuration on the TVheadend and im good to go.

Thanks everyone

@deetu That’s great!! Good to hear I guess part of the process worked to enable the module maybe, I’m still reading up on specifically enabling modules doesn’t seem too painful hopefully it’s just a couple of Lines would be needed to get rpi2 users working.

Is the firmware you are using the same as I linked above or are using a different one? If it’s different can you link it for future reference if we need it

@phate1, I downloaded the ones from this link dvb-firmware/firmware at master · OpenELEC/dvb-firmware · GitHub , 3 of them mentioned 292e, so i added them all lollll. I think adding the right header, actually did the trick

All works fine now, epg, all UK free stations, will check if the HD channels are added too. Just need to buy the mpeg2 licence and its all good. Right now the stations are getting only the audio output, but that should be fine once the licence code is emailed to me

Cheers @deetu let us know how you get on with the rest of the setup if it goes smoothly or not

Brilliant all sorted for you then gives me more hope I’ll get something working when mine turns up on Monday

@phate1 your welcome

Also i had to uninstall the TVheadend from the app store, was kinda weird and configuring was giving me so much grief, added the wheezy repository to the source list and installed with --no-install-recommends option, since most dependencies weren’t going to be need

thanks @deetu ill keep that in mind when I get to that stage

my progress so far … I ran in to the same build error that deetu had earlier to get around this:
install headers:

 set -- $(cat /proc/cmdline) && for x in "$@"; do case "$x" in osmcdev=*) sudo apt-get update && sudo apt-get install -y "${x#osmcdev=}-headers-$(uname -r)"; ;; esac; done

install source:

set -- $(cat /proc/cmdline) && for x in "$@"; do case "$x" in osmcdev=*) sudo apt-get update && sudo apt-get install -y "${x#osmcdev=}-source-$(uname -r)"; ;; esac; done 

untar source and create missing symbolic links:

sudo tar xjf /usr/src/vero-source-3.14.14-7-osmc.tar.bz2 -C /usr/src sudo ln -s /usr/src/vero-source-3.14.14-7-osmc linux sudo ln -s /usr/src/vero-headers-3.14.14-7-osmc build

solution was found here not sure if both links were required but figured it couldn’t hurt.

made allot further into the build process but unfortunately not completely.

[code] make -C firmware
make[2]: Entering directory ‘/home/osmc/media_build/v4l/firmware’
CC ihex2fw
In file included from …/…/linux/firmware/ihex2fw.c:12:0:
/usr/lib/gcc/arm-linux-gnueabihf/4.9/include/stdint.h:9:26: fatal error: stdint.h: No such file or directory

include_next <stdint.h>


compilation terminated.
Makefile:35: recipe for target ‘ihex2fw’ failed
make[2]: *** [ihex2fw] Error 1
make[2]: Leaving directory ‘/home/osmc/media_build/v4l/firmware’
Makefile:66: recipe for target ‘firmware’ failed
make1: *** [firmware] Error 2
make1: Leaving directory ‘/home/osmc/media_build/v4l’
Makefile:26: recipe for target ‘all’ failed
make: *** [all] Error 2
build failed at ./build line 491.

ill be back when I figure out what that means :smile:

1 Like

Just a quick update, all seem to be fine, rebooting and all. Just not sure how to get the HD channels available, i think that will require a manual input in the mux setting on TVheadend, still searching online for a setting that works

@deetu i have found a few places stating an old version of tvheadend was to blame for the lack of HD in quite a few cases, apparently you need to check the mux and you should have an option to select the delivery system to dvb-t2 if that option isnt available it may be tvheadend need updating if it is there and isnt on dvb-t2 change it and rescan hope that helps.

my latest update:
sudo apt-get install g+±4.9 seem to fix the previous issue

next issue:

getting lots of different failures on multiple drivers during the make procedure, found I can change the .config file to not include them in the make and it gets further each time. taking them out one at a time a the moment but taking a long time.

@phate1, thanks for the info, will check the Tvheadend version and maybe update

after a few hours of removing devices from the config file 1 by 1 they kept coming with no light at the end of the tunnel

what I did find though is this post


where someone had uploaded a compiled version of the drivers that just needed a make install, although it seems it was created at the end of last year this should still hold the 292e drivers as the comit was back in april

I ran through the make install and it seemed to go through with no errors

I have installed the 3 firmwares as deetu advised worked for him earlier

so just need to wait for the courier to deliver my stick today to test it out.

if anyone needs me ill be by the window waiting for my courier :smile:

1 Like

well my stick has arrived and … it still doesn’t work :cry:

so dmesg shows

[ 434.977257] usb 1-1: new high-speed USB device number 3 using ci_hdrc [ 435.092410] usb 1-1: New USB device found, idVendor=2013, idProduct=025f [ 435.092428] usb 1-1: New USB device strings: Mfr=3, Product=1, SerialNumber=2 [ 435.092436] usb 1-1: Product: PCTV 292e [ 435.092442] usb 1-1: Manufacturer: PCTV [ 435.092451] usb 1-1: SerialNumber: 0011412171

so I guess it see’s something

so I did the make install as above from the old build siravalon’s post
installed the 3 fimwares:

also looking at the comit im guessing the driver is in mod em28xx_dvb and looking at lsmod nothing there so I tried a modprobe and rebooted it disapeared (so I learnt modprobe is temp) so i added em28xx_dvb to /etc/modules and rebooted etc but no use either on tvfrontend the tuner isnt listed.

also another thing I noticed looking at /lib/modules I see this:

osmc@osmc:/lib/modules$ ls 3.12.31 3.14.14-7-osmc

has trying to make something that wasn’t intended for me or my version of kernel tried to set something up for a earlier kernel or something possibly the problem ?

@sam_nazarko any pointers here would be greatly appreciated

@SirAvalon you cracked this last time for someone any pointers on doing it again if your still about

thanks pete

Hey Guys, sorry, but the linuxtv drivers I have compiled was for Raspbmc and some time now. Frankly I didn’t yet move to OSMC and I also skipped the last 2 Raspbmc updates (but anyway, I think the kernel remain the same in Raspbmc). And frankly, I dont even remember how I managed to do it, it took me quite a lot of time since I am no linux expert and always have problems with the right linux source or headers. I will move to OSMC when I will buy an RPI 2 and also had the time to adapt my custom scripts to OSMC. I saw lots of changes now and this new forum doesn’t help to make it an easy job. :smile:

@SirAvalon No problem at all it was worth a shot thanks for looking we will find a way.
Until a couple of days ago never even known what kernel I was running let alone compiling / playing with one it’s a steep learning curve :smiley: lots more Reading to be done hopefully @sam_nazarko is going to swoop in an save the day :wink: