OSMC's April update is here - OSMC


Thanks for replay.
So having installed on osmc (October 2017) the ad2p following the previous procedure now must reinstall osmc (April 2018) and launch the following commands?

sudo apt-get update
sudo apt-get install a2dp-app-osmc


I don’t think a reinstallation would be necessary.

I’d recommend starting a new post if you still have issues as this thread is for announcements rather than specific troubleshooting




2 posts were merged into an existing topic: Update breaks USB sound


I’m still having unreliable video output from my Denon X3400H (mid-end newish denon) on 4k movies. Sometimes it works and sometimes I get no video, only audio. Yesterday I tried to start all my movies and they all worked. Tonight I tried again and the first movie failed immediately. I have bought new certified cables, disabled video processing in the Denon, used the HDMI input closest to the output as recommended by Denon, HPD setting in Kodi, etc…
Here’s a partial log (full log was too big and couldn’t be uploaded by grab-logs, so I kept the startup info and the portion of the log when I try to start the movie, twice):
I hope this helps.
I also, anecdotally experienced video with no audio, but I don’t have a log for it.


Can you provide any details of this?
Fix some issues with Raspberry Pi 3 B+'s Gigabit Ethernet adapter.


Hi OSMC team.
After updating from the previous version to the new april update, the blue splash screen that shows at first when powering on my Raspberry Pi 3 B+, is broken (just garbage blue stripes). It worked fine in previous version, which was installed just a few days ago (fresh and clean install) - Its not a big deal, just thought i would tell you :slight_smile: - Thanks for the GREAT work!


You’d need to post a debug log for us to be able to look in to this further. We haven’t changed anything splash screen related in this update.


I have 4 identically (raw new clean installed OSMC 2008-03-2) pi 3 b+'s (just bought 1 week ago), they ALL do the same. - I havent installed any addons nor done anything to them. - Just doing some power-consumption tests on them so far. They all use to start with a blue screen with a OSMC logo on, they still do, but the image is corrupted (on all 4) now. - … i havent even got into how to create such a log. (im a total noob) :stuck_out_tongue: - As i said, its not a big deal, i wait and see if others get this too, then they may follow it to the door with debug logs :slight_smile:




Thank you very much for this April update. Everythings just works on my side. You really doing a great job!


Hey Sam,
do you have any idea on why I’m having all these problems with unreliable 4k output?


Not following directions is why you get ignored here


I’ll start a new thread, but the tone of your post is uncalled for. I always interacted politely on this forum and I expect the same from a moderator.


Sam and mods always said to open a new post to report bugs and not use the update post comments’.

Since you can clearly see that Sam still politely asked another user above to do just that you doing the same a couple of comments after is unpolite as well.


Are you relying on HDR autoswitching or did you manually enable 10-bit output?

A new thread is probably best to address this


well, sometimes people make mistakes. I had not seen Sam post, and so I posted in the wrong thread, but my bump, after 2 days, was still polite. So the change in tone was pretty bad from the mod. Being polite is not optional, even when you correct people for their mistakes, you can still doing it in a nice way.


just started the thread. sorry about that.


Since this has been the same every time an update was released, maybe we can have a disclaimer addressing the issue and a link to How to submit a useful support request at the top of Sam’s initial post.
Not sure if discourse supports this or to what amount discussion of problems is desired in update announcements, though.


Discourse doesn’t support this I don’t think, as it grabs the post as is.
I’m not sure whether it would be read either :slight_smile:


yeah, the problem with denon and hra isn’t solved after april update. Please set this as a higher priority bug. I have a lot of movies with hra codecs and would like to watch them again :smiley:

Thanks for your great work