OSMC's April update is here

OSMC's slightly belated April update is here with a variety of improvements and fixes.

Here's what's new:

This is a companion discussion topic for the original entry at https://osmc.tv/2017/05/osmcs-april-update-is-here/

This is amazing! Thanks!

Works a treat, as usual, thank you! And the keys on my UK keyboard are working properly (almost - ~|#@"\ are fine, £ not working in Kodi but who needs that?)

Works great as usual, thanks.

Thx, works great on a Raspberry Pi 2 and ATV 1.

Thanks for the update, it has finally fixed Kodi forgetting its settings :slight_smile: it had been really annoying when it forgets its settings from changing its skin back to osmc from the confluence skin to forgetting everything so I would had to restore my settings which I would of backed up before shut down my Raspberry pi 3,this happened to me over 6 times since the previous update for the various forgetting issues it had, didn’t had any issues like this before as it had worked perfectly till the prior update.

I’m glad to hear it.

It was annoying me too as this was frequently reported but I wasn’t able to nail down the problem for some time. Thanks for your patience and giving us a chance to put this right.

There were indeed some regressions in the new version of Kodi (which was delivered in a previous update) which caused this problem.

Best wishes


1 Like

Thanks guys!

I experienced some issues while upgrading my Vero 4K via ssh with apt-get update and apt-get dist-upgrade.

Firstly, when the new samba package got installed, it came up with a curses-y dialog telling me my config was borked because it had include lines in it, and asked me to choose whether to overwrite my config file or not. Although I chose to, it looks like the only change was commenting out the ‘usershare template share’ line and adding an associated comment, so all’s well that ends well.

Later, as the connman update was being applied, I lost all network connectivity and had to power cycle. It later transpired that it had opted to change it’s IP address for reasons beyond my ken (DHCP, wired).

Following the power cycle, kodi crashed after ~5s, and I got a sad face and a reboot. Not got debug logging enabled atm, so I’m afraid I cannot share logs of this.

Seems to be working now though. And it looks like the Menu settings are being saved too!


Same here. Files seem​ likely to be corrupted, but on the servers. A lot of errors during update via apt-get and OSMC. I also did a clean install, same errors after.


If you don’t want to answer questions when updating and want OSMC to handle things, then we recommend that you update via the official method (My OSMC). Using command line tools can result in you being prompted to make choices (we follow Debian standards as a derivative)

Did you update via an SSH session?

Remember that servers like Windows Server don’t honour DHCP leases for very long, even when the same IP can be easily reused. It would be interesting to know which DHCP server you use however out of curiosity.

You probably use a skin that depends on Skin Shortcuts. This is a known issue (and heavily documented) on our forum. Unfortunately it’s not something we can fix. We recommend using the OSMC skin and official add-ons to avoid this issue.

Let us know if there’s anything we can help you with




This is a tad vague. I’m not sure what the ‘same here’ refers to.

To provid some reassurance: our update system has several stages of integrity checking. Packages can’t hit release without going through staging first, so it’s not possible for them to be corrupt.

If packages get corrupted in transit (i.e. when they’re downloaded on your device), they will not install on your system as the checksum will not validate.

Just under sixty thousand users have updated now, and the forums remain quiet, so I think things have gone smoothly. If you have issues, please start a forum post mentioning your issues and we will look in to them.



Fair enough. Actually my concern when I first saw it was that somehow the distro samba and the app store package I installed would conflict in some way and lose my configuration. But it didn’t.

I updated via an SSH session. DHCP is handled by my router (a Technicolor TC8715D DOCSIS 3 router running something built around a 2.6.30 kernel.)

I’ve gone and set up a reserved IP now, although the Vero 4K managed to keep it’s IP address since I first plugged it in until the recent change.

I’m using the stock Estuary skin. Skin Shortcuts is not installed.

The only addons I’ve installed on the Vero 4K are the popcornmix shadertoy screen saver and audio visualisations, and the universal movie scraper.

Nice update set. Rpi3 (noobs lite, dual boot recalbox) and V4K updated via Gui, no issues.

If you use OSMC’s Samba package, you won’t have problems. @DBMandrake has made sure of it.

If you set a reservation (in your router) or a static IP in My OSMC, Vero 4K will keep the same IP.

Okay – if it happens again, let me know.


I suspect that the IP problem was actually related to my fiddling around with IPv6 on the router, which may well have flushed the DHCP dynamic lease cache.

Next time I will try to remember to actually turn on debug logging before updating, in case it happens again.


Hi, i intalled yesterday the april version on Raspberry Pi 1 but the version did not change.
it is still says march-2017. the installation went ok. does it suppose to be cange to april-2017?

2 posts were split to a new topic: Sad Face after Upgrade, Corruption in codecs.py

Hi Ledderi,

I away from my pi, at the minute. But that doesn’t look right to me. Trying re-running the update and if its still not showing the correct, please raise a new topic in help and support.

Thanks Tom.

A post was split to a new topic: HDMI-cec is broken