OSMC's August update is here with Kodi v19 - OSMC

It's been a while since we released an update. We've been very busy behind the scenes and we're now happy to announce the availability Kodi v19 for all OSMC supported devices (note that these have changed, as explained below). It took a lot of time and effort from a large number of developers to release this stable update and get things to a place where we want it.

This is a companion discussion topic for the original entry at https://osmc.tv/2021/08/osmcs-august-update-is-here-with-kodi-v19/

Thank you for this great update. Whenever I have a weekend to spare :grin: will start the upgrade on my two Vero 4K+

Assuming best practices is clean install over upgrade?

I guess new images are still pending upload to ftp? Want to do a clean install.


Thank you for all the hard work that has gone into this.


These images should be available later today for those wanting to perform a fresh install.

There’s no need to perform a clean installation – but I’d recommend taking a backup just in case you find your add-ons or skin incompatible.


Hi Sam thanks for the great update just updated online with no problems player a few movies and TV episodes everything played with no problems


I had the previous test builds installed for 3D … assuming to get this new Kodi 19 update, I don’t need to change any config server entries for the test server etc. Just going into update on the main skin will update me to this latest and greatest build.

Awesome. Two days after I broke my Vero trying to upgrade to Matrix. Guess I need to buy a newer Vero.

Some issues here unfortunately. Having just applied the update to my Vero 4k, on boot I’m only seeing “Settings” in the menu and none of my library. When manually navigating to the video sources in the settings → media menu and trying to play back any file I get the frownyface crash.

My files are stored on a linux network media server and served to OSMC via NFS. The library data is stored in a MySQL DB on the same server. Looking at the DBs on the server, it looks like OSMC created the new DBs but from the debug log it looks like there’s an exception on boot when trying to update the databases (even when temporarily using the root DB user for OSMC).

2021-08-08 14:52:36.384 T:2716 INFO <general>: Attempting to update the database MyMusic82 from version 72 to 82 1084 2021-08-08 14:52:36.385 T:2716 DEBUG <general>: Mysql Start transaction 1085 2021-08-08 14:52:36.393 T:2716 ERROR <general>: SQL: Can't determine list of routines to drop. 1086 2021-08-08 14:52:36.393 T:2716 ERROR <general>: Exception updating database MyMusic82 from version 72 to 82 1087 2021-08-08 14:52:36.393 T:2716 ERROR <general>: Error updating database MyMusic82 from version 72 to 82 1088 2021-08-08 14:52:36.395 T:2716 DEBUG <general>: Mysql rollback transaction
I’m not sure how best to proceed here other than rolling back. Video playback should work via manual navigation regardless of whether the DB migration worked, and the DB migration should be working at least in terms of access/permissions as the previous upgrade cycles have worked fine and the user has appropriate permissions.

No support requests are handled from this News announcement thread. Please create a new, appropriately titled thread with relevant info and complete logs to receive support.

What does this really mean for us on RPi 2/3?
As I read it:
-no hardware decoding (will it work good enough for daily use, will it run warm?)
-no deinterlace
Any RPi users running it who can share experience before upgrading?

You should still have hardware decoding for h.264 on pi 2/3, I think, but not for mpeg-2 or vc-1. 480i or 576i stuff can be played in software, but you won’t be able to play 1080i because of the lack of hardware deinterlacing. MVC 3D won’t work either.

Perfect timing, since i’ve just “destroyed” my debian+kodi installation by being stupid and upgrading it.

Let’s try good “ol’” osmc!

On Friday night I upgraded to a new major release of the OS on my NAS (Synology).
For whatever reason, that broke connectivity with my R-Pi OSMC which has been working fine for ages. Couldn’t find the problem (been so long, I couldn’t remember how I had set it up). So I just did an NFS mount and used that.

Went to test it today and saw the notice about Matrix. I don’t have many plugins or anything special, so bit the bullet.

After it finished doing its thing, it all looked ok. Apart from no sound …
Looked at the sound settings, don’t really understand what they meant, but noticed one mentioning Sony - and I have a Sony TV, selected that, and sound works.

iplayerWWW plugin is working - looks like its using adaptive streams now (can’t see any setting to switch, and it looks like HD … so probably is).

Actually, relatively smooth. Much better than I was fearing. I will try out a movie this afternoon to give it a workout.

Thanks for the work!

So I updated my Vero 4k + and now Plex loads movies much slower where before the update Plex started movies nearly instantly.

Any idea on this? I also posted a thread about it in the support section.

I just updated my Vero 4k and the update installed with out a hitch, the only plugin that was disabled was the skin helper which I installed back in the day and had forgotten about it as I don’t really install plugins unless I needed them for some function.
Needless to say the Device is running fine as far as I can tell, going to use it for a few days and see if there is any issues which I doubt it considering how careful the OSMC team is when it comes to updates, especial one that updates the core OS with a major version upgrade, I’m sure over the next few weeks/months the remaining addon’s/features will be updated and brought up to full functionality as it was before the update and we will have a OSMC thats is current for a long time.

So good work on the time put in the development by the team for this update as it wasn’t easy with what I have seen in the topic about this and I do like a updates that install cleanly (at least for me) and the Vero 4k running as I want it post update. So I’m looking forward to what comes next in the future for updates.

I just installed the new official version but still i got the problem with covers from collection not showing :frowning:

What is the problem???

I use advancedsettings.xml to connect to a MySQL/MariaDB database. Updated to the devel branch. Database upgrade “successful”. But library was empty. Had to mysql_upgrade the database before upgrading/starting Kodi. Dropped the new MyMusic82 and MyVideos119 databases and restarted Kodi to fix this.

For more information:

shared library (mariadb) problem after migrating to matrix 7