OSMC's August update is here with Kodi v19 - OSMC

This issue is probably best addressed on the Kodi forum as I’m pretty sure it isn’t related to OSMC, but if you would like us to review it please start a thread for it and include relevant details specifically if you are talking about all posters or just some, and if you are using nfo files. On a quick glance of your post history I would suspect that either you have something generating nfo’s that are not completely correct (thus why refreshing made the artwork show up) or else you have something out of sorts in your scraper settings. I would maybe suspect something there along the lines of a language issue with not having a fallback language set or else your source was set with an outdated scraper that needs to be switched.

Looking at the linked thread, that looks to be precisely the issue I’m having (in my case it’s MariaDB 10.3). I’ll run the upgrade on the old DBs and drop the new empty ones so that kodi rebuilds them again.

Thank you very much for that pointer, very much appreciated!

1 Like

You’re welcome, glad I could help my friend!

Awesome job guys !
thanks for the update. It’s already on my vero4k and rasp4 running really good.
No major issue with the addon and stuff.
Really great update.

Very nice job guys! Will update right away.
So no clean install is required. Thats nice too.

Did the scope skin had an update too?

Will this remove -dev from sources.list for those already on Matrix builds?

No, if you don’t want to install any new test builds, you need to remove it by yourself.

Thanks! Upgraded and apart from a bunch of add-ins, that I no longer use, were deleted, all seems fine. Looked weird at first, until I realised that it had picked 1080i as resolution. Changed to 1080p and all looked good!

I experienced the same. After the update, for some reason the resolution was set to 1080i and the refresh rate was set to 59.94 Hz. I guess this might happen depending on which TV is connected to the device. Maybe you could share your model. I have a LG C9.

1 Like

SAMSUNG 55’’ 4K/QLED/QE55Q95T. I saw that 59,94 as well. Wonder why?

Okay, thanks.

Just doing the update now, but it came up with quite a few incompatible apps. Inc vpn manager and some others. Don’t know full extent as it’s been building the menu for 5 or 10 minuits.
If not working I assume I can go back by doing a fresh install and then using the latest backup?

I upgraded last night. Went smoothly. Thanks and well done. My display was flickering just a little and noticed it was also set to 1080i. I changed it to 1080p and the flickering stopped. I have a LG 43MU7300PUA TV.

I also had a note of incompatible addons. Is there a way to quickly delete those addons that have been disabled? I didn’t capture what addons were deactivated earlier.


I was under the impression that they were automagically deleted? Can @sam_nazarko verify? Perhaps a sticky here about the interlace issue would be in order? :slight_smile:

Had to explain to the wife what “interlace” meant. Luckily did I cut my teeth repairing TV sets from the age of 13…

As the images for the new update are now available directly I think I might try a clean install with the new image later today. I’m gonna report if it also happens with the clean install.

Brave man :slight_smile: I must admit that I felt a little bit like Pandora when hitting OK after reading the frightening disclaimer, but our new Samsung TV works without XBMC so we took the chance.

My Pi4 has the PoE HAT fitted, but at the moment I can’t run a PoE cable to where the Pi4 will be sited. So when testing OSMC on the Pi4 I connected the official power supply to power the device and connected to the network/NAS via Wi-Fi.

Using the PSU rather than PoE to power the device, PoE HAT makes a horrendous amount of noise - screeching and clicking whenever there is any activity (i.e. boot-up, scanning library, playing video). It’s REALLY loud, I could hear it from the next room, and makes it impossible to tolerate when playing media.

Eventually I disconnected the HAT and tried again and the noise stopped. I also tested connecting an Ethernet cable with PoE in another room - again, no noise.

So just a warning for anyone who experiences the same combination of circumstances - if your Pi sounds like a 56k modem being attacked by a banshee, you may not want to use a Pi4 with the PoE HAT if it’s not actually using PoE.

(I don’t think this happens if using Raspberry Pi OS with the same combination of power supply/HAT, which is why I posted this here)

I spent the last couple of months of Pi 4 development using the POE + HAT and didn’t experience this issue. I’d recommend trying to power via POE and seeing if you still have an issue.

We’re looking into that. I think it happened on the last major upgrade as well.


OK. Wonder if it even worth fixing. Just document it.