OSMC's December update is here with Debian Stretch and Kodi 17.6 - OSMC


Updated 2 * Vero 4K (one with TVH). No issues to report.
Many thanks @sam_nazarko and team for great product and great support :slight_smile:


Sorry I wasn’t precisely I mean from this one [TESTING] OSMC images for Debian Stretch


Those images had some problems. I’d recommend a fresh installation or you may have some problems updating and installing packages from the App Store.


Yeah I know the bug within the app-store but how it’s about updating from this to new versions …01.2018 and next, because this version works for me


The bug has been resolved with the latest images. I’d recommend an official image from the OSMC website. We won’t be able to provide any support or upgrade paths for the older testing images.



Okay then I will reinstall it in the next time. DAMN even the buggy version works fine


I am sorry I am late to report this, but I just noticed that my update has been failing. I have a VERO 2 and was having the same sort of issue with the last big update, eventually wiping the VERO 2 and starting from scratch.

Seems like we are at that point again:

I ran:
apt-get clean
apt-get update

This failed at:
Err http://ftp.debian.org stretch/main armhf Packages
404 Not Found
Fetched 13.3 MB in 43s (302 kB/s)
W: Failed to fetch http://ftp.debian.org/debian/dists/stretch/main/binary-armhf/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

I also tried:
apt-get dist-upgrade --fix-missing

Which also failed with:
E: Failed to fetch http://apt.osmc.tv/pool/main/v/vero2-source-3.10.105-8-osmc/vero2-image-3.10.105-8-osmc_8_armhf.deb Hash Sum mismatch

E: Failed to fetch http://ftp.debian.org/debian/pool/main/t/tzdata/tzdata_2017c-0+deb9u1_all.deb Hash Sum mismatch

E: Failed to fetch http://apt.osmc.tv/pool/main/w/wireless-firmware-osmc/wireless-firmware-osmc_1.1.4_all.deb Hash Sum mismatch

E: Failed to fetch http://apt.osmc.tv/pool/main/m/mediacenter-addon-osmc/mediacenter-addon-osmc_3.0.654_all.deb Hash Sum mismatch

E: Failed to fetch http://apt.osmc.tv/pool/main/m/mediacenter-skin-osmc/mediacenter-skin-osmc_17.0.2-6_all.deb Hash Sum mismatch

Any help?


The local Debian mirror to you looks like it is out of sync. It should start working again in a couple of hours.

If you continue to have problems, please start a forum post as the release thread is not ideal for troubleshooting.


Awesome work on the Stretch upgrade! I did it just last night and it worked really smoothly. Thanks for being so great.


The updates breaks RetroPie, when I tried running it gives the following error: libboost_date_time.so.1.55.0 cannot open shared object file

  1. The news threads is not for reporting issue (open a new thread)
  2. You must recompile RetroPie against the new libs


Vero and OSM team, I sadly have to report to you that your Vero 4K is very, very boring. Every time I use it, it works so flawlessly I don’t even realize there’s an OS and hardware running this. So thank you for your boring device :grinning:


HDMI audio passthru is broken completely — it decodes to multi-channel now any audio type in any case. Vero 4K reinstalled from scratch, no luck.


Shouldn’t be. It seems to be working for others. Please start a forum post with debug logs and a screenshot of your audio settings so we can assist


Fixed. Installed previous version from scratch & updated up to 2017.12-1 from «My OSMC». Now audio passthru works like a charm.

Russian translation is heavily incomplete and reverses to English after device is rebooted.


Turn off Change Language via CEC in Settings -> Input -> Peripherals.
This will be resolved in the next update



Woah! Unexpected. But CEC setting does the job, thank you.


Update went flawlessly… Perfect job guys!


Your continuous support is from beyond this world.
Thank you a gazillion for all your efforts.
They are appreciated and thank you for this wonderful Vero 4K.


Vero 4K --> Denon 3400H --> LG C7

Since this update it seems CEC is switching my TV to a wrong input as soon as I start playing a video.
I don’t need CEC and if I can disable it somehow I would be happy.