OSMC's December update is here


#1

All of the OSMC team would like to wish you a Happy New Year!

OSMC's December update is here with a large number of improvements. In particular, we've improved HDR and bit depth switching further; so this should now work well for most users without manual configuration. Some users with LG displays may find that they need to set 'Force 422 colour subsampling' under Settings -> Display for reliable 4K playback.


This is a companion discussion topic for the original entry at https://osmc.tv/2019/01/osmcs-december-update-is-here-2/

#2

Thanks for this I can finally watch 4K via the Vero 4K+ on my LG B8 now. They still didn’t work after doing the update without changing settings but as mentioned at the start of the post once I enabled “Force 422 colour subsampling” everything was hunky dory, tested every 4K file i have (just a single episode from the TV shows though, i’m not that patient :blush:)and not a single “no signal” message from the TV and HDR is activating as it should. Happy days.


#3

Thanks for the Update and your work on these days! Amazing!
But maybe I’m blind - I can’t find “force 422 Colour Subsampling” in Settings - display (Expert Mode) … I’m definitly on December-Update 2018.12-1, to be exact, on “17.8-383” … Is it because I’m on Leia and those fixes are coming first for the Stable Versions, and later for Leia? Additionally, I can’t use the v18 OSMC Skin anymore (don’t know if it worked before) … wanted to switch the skin, to check if the settings are skin related, but OSMC Skin is still “v18 RC1” and I can’t update it. If i want to use it - sad face, and switching automatically back to my currently used skin (Arctic: Zephyr) ?


#10

This could be the reason:

This is indeed strange. I’ve checked back with the team as I currently can’t access my own v18 setup. The issue doesn’t seem to be common, but a bug on your setup.
What you could try is resetting your OSMC skin settings completely. Accessing your device via SSH, navigate to /home/osmc/.kodi/userdata/addon_data/skin.osmc.v18alpha and delete the settings.xml. After rebooting your device and switching to the OSMC skin, you should navigate to Settings/Interface/Skin/- Configure skin…/Backup/Reset and click both Reset all menu items and Reset all skin settings.
This should reset the skin to a default state that should function without issues.

If there’s still an issue, come back to us and we’ll try to assist further.


#11

Yes — you need to run the stable version of OSMC to get these changes.


#12

What is:
Added support for controlling video output range on Vero 4K +


#13

You can now set Limited or Full range under Settings.


#14

I have an LG B7 and Vero 4k. Should I be using the new force 422 colour subsampling?


#15

Only if you receive ‘Out of Range’ or get no signal when playing 4K content; but the B7 series should not be affected.

Sam


#16

For 4K, 23.976Hz material, my system seems to be happier with 422 12-bit than it is with 444 10-bit, meaning the setting is useful; but for 4K, 50/59.94Hz material, it’s happier with 420 10-bit than it is with 422 12-bit. Could that setting possibly be divided up, so we can force 422 only for certain frame-rates and/or resolutions?


#17

That sounds quite complex.

Can you elaborate on this in more detail? What does ‘happier’ mean?


#18

With each release, we discover something more about these pesky LGs. It surprised me when some ppl reported 422 working better at 60Hz than 420 as it needs a higher tmds. If we’ve mis-read those reports, and 422 is not necessary at 60Hz then we can turn that off. Or maybe the issue at 60Hz is mainly to do with cabling. I’d like to get feedback from other LG owners (including 2017 owners - not sure if Sam is right about B7s not being affected) before deciding what to do next.


#19

“Happier” as in “less likely to lose HDMI signal lock”.

It doesn’t have to be too complex - you really just need two controls rather than one. You could either have a second checkbox that says “only force 422 for 4K/24 or 25”, or a second box that says “don’t force 422 for 4K/50 or 60”; either of those would do.

I have an LG G6, incidentally.


#20

Hi Sam,

Couple of questions…
*** Fix brightness and contrast values on Vero 4K + so they are correctly calibrated.**
Can you elaborate on this? There is still a certain amount of black crush on HDR material with my Panasonic DX902 that is cured by bumping the brightness to 51%. Not sure if it’s the Adaptive Backlight Controls for the TV being a bit over-aggressive or the Vero itself.
My only options are to bump brightness to 51% and “apply to all” which then messes up the SDR movies or change the settings on each HDR movie one at a time. #firstworldproblems
*** Fix an issue where brightness was not persistent**
Is this correct? I thought it was contrast settings that weren’t persistent.

Also, do all of the bug fixes and improvements listed for the 4k+ also apply to the 4k?

Thanks for all your hard work!


#21

Yes.

Prior to this, Kodi was not scaling brightness correctly as the kernel was expecting different values.

Both were not persistent. Brightness has been fixed; contrast has not; but is on the list.

Sam


#22

That was quick!

Did the brightness scaling affect HDR & SDR material?


#23

It affects all content played with hardware acceleration.

Cheers

Sam


#24

Could there be an option to have different values for SDR & HDR without having to go in and adjust each movie one at a time?


#25

Kodi would need to be aware of differences between HDR and SDR first; unless we can find a robust way of handling both with a single value.


#26

No worries.
I think it has more to do with the backlight control settings on my TV than the Vero anyway.
Unfortunately changing the brightness settings on the Vero is much better at resolving black detail without affecting the overall black level than the brightness control on the TV.