OSMC's July update lands (a little late) with Kodi 15

Hi,

sudo apt-get update && sudo apt-get dist-upgrade

And Update Manually is same thing ?

which is better ?

Hi

That is correct. Yes. If you do that, we cannot reliably know when to restart Kodi, so it is recommended you do it via My OSMC to ensure that Kodi starts again after.

Sam

Yes, except that you will likely still have an icon on the GUI that advises that an update is available. Running the MyOSMC update function will remove this icon.

Indeed.

Unless you have a specific need to use dist-upgrade (you’re at work for example), I’d recommend you upgrade via the TV

Sam

Ok,

Something else. I feel a slight slowdown (fps slow) in menus home or playlists, I come back during playback

Is it because of the version 15.1?

Please create a NEW THREAD in the appropriate Help and Support category for technical/support issues! The release announcement thread is not intended for this.

Great thanks!! Updating again solved the problem with hifiberry! Works like a charm!

I upgraded via GUI. Since that I did a command line upgrade too. I’ve restarted several times.
Here you can see the logs:
http://paste.osmc.io/ecodumosoc.vhdl
http://paste.osmc.io/pahavumucu.vhdl
http://paste.osmc.io/qirosuqofe.coffee

If I turn off and on the monitor it works. But it’s very annoying.

Just a quick data point on a Raspberry Pi 2.
I had changed my config.txt to add “dtoverlay=sdhost”.
After a reboot, dmesg shows:
mmc0: sdhost-bcm2835 loaded - DMA enabled (>1)

I have been running fine for the past 24 hours, 2 updates and adding the Plex Media Server package.
All seems well at this point.

is it possible to turn off adaptive seeking?

Hi Sam,

I’m having problems in the database update (from version 90 to 93). I get a Segmentation fault, and an empty (93) database. Further attempts to load kodi show the sad face (becase there are no tables in the current database).

Thinking it could be a memory issue, I enabled temporariliy 512Mb of swap, but the result is the same.

Rasperry Pi 1, model B (512Mb).

Can I force the database update manually? How should I proceed? Is there any way to revert to kodi14 (or any other previous version) for the sake of exporting the database and importing it on a new database?

Thanks,
Julian.

I believe you can change the skip steps in Settings.

Sam

Unfortunately in our testing we also saw the sad face too with the initial boot when the database is upgrading.

I would suggest dropping the empty schema and, if you have one, using a client with more resources such a s a desktop to perform the database upgrade.

Hope this helps

Sam

Thanks for your reply. I noticed it happened too with the windows version just downloaded from their site :frowning:

What I did to get it working again (I used the windows builds for speed):

  1. Start kodi14
  2. Export the video library
  3. Drop mysql databases
  4. Start kodi15 (the databases are created empty)
  5. Import the video library

i can’t understand… how i can know if i use mySQL database ?

Do you know you use MySQL?
No?
Then you don’t use MySQL.

1 Like

See: http://kodi.wiki/view/Skip_steps
“With no more than a single negative or positive step configured,
together with Skip Delay set to none, then Kodi will instantly skip
without a delay.”

2 Likes

Since the last update on my Raspberry pi 2, i can’t play anymore many movies and i feel a big slowdown on the most of the others.
After some research, i understood that the default player become mmal (dvdplayer) and not omxplayer like before.
After setting back omxplayer as default player and unselect new dts-hd decoder (because omxplayer doesn’t seem to be compliant). All works fine now !!! Children are happy !!!