OSMC's June update is here with Kodi v18.7 - OSMC

I can’t think of any changes that would cause this in this update, but fast forward and rewind aren’t really supported by Kodi.

If you would like assistance with this please start a new thread with some additional information such as what remote your using and what action did the keys used to perform. If you can post the keymap as well this would be helpful.

OSMC’s June update doesn’t work on RPi 3B+. I tried to install the update but after the installation OSMC doesn’t start, on the screen there is :-(, the same issue I had with OSMC’s March update.

Now I’m coping the imagine that I saved before to start the update, I hope well.

We haven’t had other reports of this. I suggest starting a new forum post with logs so we can get this resolved.

Great. Thank you.
The Kodi people also seem to have fixed a big which caused a crash everytime I tried to scan a flac file. Keep safe.

I had the same problem with my RPi3B+ not booting anymore. I’m not sure whether I have accidentally rebooted through the update though because I had no screen at the time.
I’ve tried some things but the mayor problem seems to have been that the config.txt file was empty.
The problem was solved in this thread.

Does not work for me:

osmc@osmc:~$ sudo apt-get install --reinstall vero3-mediacenter-osmc=18.6.0-13
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Version '18.6.0-13' for 'vero3-mediacenter-osmc' was not found

So I just got my new Vero 4k+ (only because of 3D ISO / MVC support), installed all updates just to find out that 3D is broken with the newest update and there is no way to revert back?!

You can certainly revert back. You should post some logs so we can see why this is not working.

3D isn’t broken - it’s just not included as part of the standard build yet because it is still an experimental feature. As such, we are not advertising MVC support yet. If you want this functionality, you must use test builds for now.

Thanks Sam!

Ok, so I enabled logging, did a reboot, performed the suggested command line prompt that still does not work (same error message as posted above) and uploaded the log file:

http://paste.osmc.tv/yubaxelogu

How can I use a test build that has full 3d support?

Your sources.list shows that you do not have the 4.9 repository added.
You can add it by following the instructions in the first post in the 4.9 thread, then run sudo apt-get update and install the 3D build as you attempted before.

Haha… that was quite some fun for someone who is completely new to OSMC and Linux.

But anyways, it worked. Thanks Sam, great support!

Just been notified of a 2nd June update. Any info on this?

There was a fix for SMB for some Vero users. This was pushed a couple of weeks ago.

1 Like

Just wanted to say thanks :slight_smile:

1 Like

Is anyone else experiencing a lot of sad faces after this update?

You should probably start a new post with logs. But your post history suggests you are not on the stable build

Sam

I updated to the 4.9 kernel, I guess that’s what you mean by not being on the stable build. I will try getting some logs with debugging enabled, but the sad faces appear randomly so they’re tough to catch.

As far as I’ve understood, there’s no way to downgrade to the stable build. Is that correctly understood?

Indeed. You would need to reinstall instead.

I’m on 4.9 and have also been getting loads of sad faces since the June update. But going back to Kodi 18.6 seems to have stabilised things, at least as far as the sad faces are concerned. That doesn’t require a reinstall.

Ah, good to know it’s not just me. How would I go about downgrading Kodi to 18.6?