OSMC RPi boot problem

Dear all, the energy line has been interrupted and RPi 3B+ is not available.

The green led flashes 3 or 4 times and red led is stable. Probabily, the problem is start.elf file.

I have disconnected my HDD usb.

I have connected microsd on my pc Windows but the lnux partition is not available.

How to solve it?

When I connect RPi on TV through HDMI, I have not see anything.

Regards.

What would you do even if you could access it? (BTW start.elf is in the /boot partition, which is FAT format.)

The simplest and least-hassle method is probably a reinstallation from an OSMC image.

There is two partitions. When you plug it into a Windows machine it will give you a message about the ext4 partition (don’t format it, just close the dialog box) but it should have mounted the second partition. There should be a file called “config.txt” at the root of that partition. If you open that file is it empty?

Yes, partition FAT32, file config.txt is empty.

I opened partition ext4 with ExtFS for Windows and I see /boot/ and it is empty.

The /boot in the ext4 partition is a mount point for the FAT partition, so should be empty.

Put the following in that file and then see if it will boot your RPi.

gpu_mem_1024=256
hdmi_ignore_cec_init=1  
disable_overscan=1
start_x=1  
disable_splash=1
gpu_mem_256=112  
gpu_mem_512=144  
sdtv_aspect=1
3 Likes

Thanks so much so much. I have solved the issue.

Soluction: I put the microsd in the PC slot. I put the following lines in the config.txt file of the FAT32 partition.

2 Likes

Hi, could you solve this issue permanently in the next releases?

Today, I lost electricity (main swith off of my home) and therefore I did not turn off the RPi properly, on restart I had the problem. So I added the lines, you recommended me, to the config.txt file and solved the boot.

Regards.