OSMC's June update is here with Kodi v18.7 - OSMC

sudo apt-get install --reinstall vero3-mediacenter-osmc=18.6.0-13

(I think).

Thank you!

I upgrade my Vero4K last night to the Kodi 18.7 release. And everything stopped working. Now 90% of my videos play for 5-30 seconds and then they close. After a hard reboot I was able to watch a movie, but the next item I played closed. Went into my TV shows and tried to play un-watched and previously watched and almost all of them closed. I checked the encoding and the ones that are closing are encoded the same as those that are playing. I have been digging through trying to find ways to fix it. I did a factory reset of Kodi, and added in my video paths again. Same issue.
I have not used Linux since the 90’s so remember next to nothing, but I was able to putty into it, and I tried the Kodi downgrade, you [angry.sardine] mentioned but it tells me it cannot find the file. "“sudo apt-get install --reinstall vero3-mediacenter-osmc=18.6.0-13"”
I changed it from vero3 to vero4 & vero4k.
I am not sure where to look to see what versions may be available to restore to or to verify.
Right now I have a brick, so any help would be appreciated.

I am replying because it seems to be the same/similar issue, but will open a new conversation if that would be the better way to go.

Many Thanks.

Are you using SMB?

If so – go to Settings -> Services -> Enable SMB mitigations or update your NAS so it isn’t using a broken implementation of SMB.

Hey Sam,
Yes I am using SMB, and it was still set for a MAX of SMB2. I changed it to SMB3 max, and the videos are now playing. What an easy fix. I appreciate your quick response on this. After doing all of the digging, I am thinking about activating NFS and changing the connection on the OSMC. Would this cause any issues with anything if I remap everything? I really do not have any speed or buffering issues, so do not want to rebuild just to change it.
Thanks again for the quick response.

Are you using the library mode?

If you don’t have issues with SMB now, I wouldn’t change anything. If it ain’t broke…

Yes I am, and nope, not worth risking it to change it.

If you really wanted to you could setup nfs on your nas, make a system mount for it, and then use a path substitute which would allow you to maximize performance without modifying your library at all. It would also have the benefit of being easily reversible if you had any issues as all you would need to do is remove the path sub and your right back to using the Kodi SMB paths.

i can made a possibily stupid question ?

Why hasn’t a version with “new” 18.8 of kodi ? why does it not bring essential changes compared to the current 18.7 ?

The OSMC team were focusing on the Debian 9 ‘Stretch’ to Debian 10 ‘Buster’ upgrade as that was a higher priority, the idea was that this would be rolled up together with the Kodi 18.8 update and delivered together, this is in testing now if you wanted to try this or you can wait just a little longer for it to be officially released.


Kodi v18.8 doesn’t really bring many significant changes for us, so the focus is to deliver it with Buster.

1 Like

While trying to re-install my Vero4+ to kernel 4.9 Osmc 18.6… I couldn’t find back version 18.6.0-13.
(figure out my install went to 18.9 :frowning: while I wanted to avoid this one… I probably did a mismanipulation)

Is 18.6.0-13 still available nowadays?

Kodi 18.6 and the 4.9 kernel won’t work together.

Yes, but you’d need to do a full reinstall. Looking at the date of Sam’s original post, which announced Kodi 18.7, you’re probably looking at image 2020.03-1.

1 Like

Hi Sam,
I’m lost now. What is the combination you do recommend now for 3D MVC as kernel+kodi versions? Now that I am reinstalling anyway, I’ll go to the latest valid combo until Matrix support ok 3D MVC (if this is not already the case more or less unstable?).

If you need 3D support you’ll have to install a test build with the v4.9 kernel. See this thread: [TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

3D support in the standard (non-test) software is coming, but not until the first Matrix release.

Thank you, fierce enemy of the angry birds.
In fact I was with kernel 4.9 since a while but I have probably lost track of changes in the test sources as Darwin point out in another thread. Thanks for the relevant advice anyway!

Whenever I search for updates it says no updates are available. It has done since Nov 2020 update. What do you advise? Thanks.

Expect next update by the end of the months (if all goes well).

Apologies. I mistook this for a June 2021 post, as it was at the top of the discussion, but it was a June 2020! My mistake. Apologies.