OSMC's June update is here with Kodi v20 - OSMC

Great update, thanks! everything works fine after update!
any clue about the specifications of the new “vero4k+++”?? ETA??

There is no specific ETA yet and until it is ready for sale some of the specifics are being withheld. There is two threads where you can find what has been revealed with the main one being…

1 Like

Raspberry PI 3B+ here.

The screensaver (a simple image slideshow) hangs after a few hours. Kodi it not responsible. Killing Kodi with “kill” shows the sad face (expected), but it doesn’t show kodi main screen when kodi reloads. Kodi seems to be running but the screen still shows the sad face.

The only way out is rebooting the Raspberry PI.

Checking “dmesg”, I see this line every second:

[197730.568018] [drm] Resetting GPU.
[197731.608088] [drm] Resetting GPU.
[197732.568102] [drm] Resetting GPU.
[197733.608013] [drm] Resetting GPU.
[197734.568123] [drm] Resetting GPU.
[197735.608173] [drm] Resetting GPU.

This is happening since upgrading to 2023.06. I was very happy with KODI 19.5, until that update.


I got several OSMC updates since 2023.06-1, like 2-3 already, but version is still 2023.06-1.

This would surely be something particular to your installation as judged by the lack of reports of similar behavior from others. If this is an attempt to ask for help then I would suggest starting a new thread with debug logs attached.

Hi. I’ve a 3b+ as well and experienced random lock ups after updating to the June version. After trial and error it seems to be a kernel issue with the 5.15 version. Reverting to the previous 5.10 version solved the hangs for me.

sudo dpkg-reconfigure rbp2-image-5.10.78-7-osmc

1 Like


Do you know how to reinstall it, when it has been purged by an update?

Here is my problem :

“sudo dpkg-reconfigure rbp2-image-5.10.78-7-osmc
dpkg-query: package ‘rbp2-image-5.10.78-7-osmc’ is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files.
/usr/sbin/dpkg-reconfigure: rbp2-image-5.10.78-7-osmc is not installed”


Just checked and the server still has the package to download

osmc@osmc:~$ sudo apt list rbp2-image*
Listing… Done
rbp2-image-5.10.78-7-osmc/now 5.10.78-7-osmc armhf [installed,local]
rbp2-image-5.15.83-3-osmc/unknown,now 5.15.83-3-osmc armhf [installed,automatic]

You can install it as a normal package

sudo apt-get install rbp2-image-5.10.78-7-osmc   


I tried but it seems that something is missing :S

sudo apt list rbp2-image*
Listing… Done
rbp2-image-5.15.83-3-osmc/unknown,now 5.15.83-3-osmc armhf [installed,automatic]

sudo apt-get install rbp2-image-5.10.78-7-osmc
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
E: Unable to locate package rbp2-image-5.10.78-7-osmc
E: Couldn’t find any package by glob ‘rbp2-image-5.10.78-7-osmc’
E: Couldn’t find any package by regex ‘rbp2-image-5.10.78-7-osmc’

I’ll try to examine my sources.list file.

@h_ramus @Dey_Dey
I’m about to downgrade my kernel to 5.10 just like you.
But I want to make sure before you had/have the same symptoms as me (random freezes after upgrading to June version) :

Thanks in advance

Hi Boulotaur,

Yes I think this seems to be quite similar.
It freeze when reading too much video (about 5h). And I can see a lot of kernel traces after reboot.
Everything was OK before June update yes.


The freeze usually happens after 5/6 hours
Thank you so much !

Sorry, you’re correct. Just tried to reinstall it and fails to download

osmc@osmc:~$ sudo apt-get install --reinstall rbp2-image-5.10.78-7-
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Reinstallation of rbp2-image-5.10.78-7-osmc is not possible, it cannot be downloaded.

Apologies but it seems only the latest kernel is available from the packages list. Alternatively, you could download an older kernel from the osmc server and install it with dpkg. Version 5.10.78-5 seems the latest archive from 5.10.


I’ll caveat that this likely not great advice but may help with your GPU lockups until a newer kernel version is available.

My dmesg would be full GPU resetting messages. Discussion on a previous similar issue in https://github.com/raspberrypi/linux/issues/3221.


The “https://ftp.fau.de/osmc/osmc/apt/pool/main/r/rbp2-image-5.10.78-5-osmc/rbp2-image-5.10.78-5-osmc_5.10.78-5-osmc_armhf.deb” package is installed and in use.

I’ll give a feedback as quick as possible.

Can I ask you how did you get the package rbp2-image-5.10.78-5 ready to install ?
I’m having the same problem as you right now “Unable to locate package rbp2-image-5.10.78-5-osmc”

Of course!

I downloaded the package from link posted here (from the osmc apt repo) : https://ftp.fau.de/osmc/osmc/apt/pool/main/r/rbp2-image-5.10.78-5-osmc/rbp2-image-5.10.78-5-osmc_5.10.78-5-osmc_armhf.deb :

wget https://ftp.fau.de/osmc/osmc/apt/pool/main/r/rbp2-image-5.10.78-5-osmc/rbp2-image-5.10.78-5-osmc_5.10.78-5-osmc_armhf.deb
sudo dpkg -i rbp2-image-5.10.78-5-osmc_5.10.78-5-osmc_armhf.deb
sudo dpkg-reconfigure rbp2-image-5.10.78-5-osmc
sudo reboot

After more of 10 hours playing videos, there is no problem.
So I will continue with the 5.10.78-5 kernel.

Many thanks to @h_ramus !!!


Thanks again Dey_Dey
I just downgraded to version 5.10.78-5 with your help
(You might add the wget part in order to download the .deb ?)

I thought the installation process went really fast (with no errors though). I was expecting 10-15 minutes in order for the new image to install properly. Instead it ended up in 1 minute

And now I can’t help wondering if it DID install anything over the previous one
How would I know the 5.10.78-5 image is now actually running ?

uname -r

1 Like

If manually downgrading the kernel solves this, I wonder about what is going to happen when OSMC publishes a kernel update.