OSMC's March update is here with Kodi v18.6 - OSMC

well, downgrading has proved it’s the March build that’s the issue, so that’s something at least.

1 Like

Okay! Noted. Thanks for the update. I do have a Pi 3 with OSMC rn. Guess I will just wait :slight_smile:

Works great. Thanks Sam

Thanks for the hard work, it works like a charm on my Vero4k+.

On my Vero 4k, after I installed the March update the random teaser film icons on the Kodi main screen (which used to be displayed when the movies menu was activated in the sidebar) have gone. Same for the TV series. I don’t know how to get them back.

I read about the remote long-press support in the newest update (2020.03-1) and went to install it, which it did just fine without errors. Am I missing something very obvious as none of the long-press actions seem to work (OSMC Remote - Long Press Keymap Guide), do I need to do something to activate the new system?

Also when I got the Vero 4K+ couple of weeks ago the volume buttons have never worked, when I press the volume down button I get a “Volume 100%” on the screen, pressing volume up doesn’t show anything. Don’t know if that has anything to do with this, as didn’t really need volume control as I use my TV remote for that.

Any ideas?

Here are my logs: http://paste.osmc.tv/olehupikob

That sounds like you have passthrough enabled.

That long-press information is only applicable to the OSMC remote which I don’t see as being plugged in according to your log.

Regarding the Volume you only get volume control when using passthrough by using CEC. If your TV has CEC (BRAVIA sync) make sure it is turned on in your TV’s settings as well as in Kodi (settings>system>input>peripherals). If you don’t have working CEC on your TV you will have to disable passthrough to control volume through Kodi.

Hmm, I just hope that the widget subsystem hasn’t been changed in the update.

Check you settings here:

Settings -> Interface -> Skin -> Configure Skin -> General -> Customize Home Menu -> Movies -> Manage widgets

@sam_nazarko I do have it enabled. It seems I can get the volume to work if I use the Keymap Editor and bind the volume keys to volume up and volume down but as I’m using the tv remote anyway so that’s a non issue for me.

@darwindesign That is odd as I’m using the OSMC remote that came with the Vero 4K+. The only reason I have CEC active is that when I change the source on my tv to Vero it turns it active.

Should I try to to pair the Vero remote? Also how do I do that?

Are you sure you’re using the right receiver? You might have an OSMC remote but that dongle isn’t on that we’ve ever produced, which explains why you’re getting this issue.

It seems like you may have tried to pair the remote with another similar device or mixed up the dongles.

I only have one Vero 4K+ box and I don’t have any other dongles it could connect to. It seems to control it just fine but if it doesn’t for some reason id itself correctly it would explain why the long press support isn’t working?

Where did you get your Vero from? Not only is that dongle not from OSMC but the remote isn’t either as I notice in your logs that it is sending out at least one key that has never been programed to any OSMC remote.

I got it from your store, order number #28921, March 4, 2020.

I would suggest contacting support and raising a ticket and returning the remote and dongle. We don’t manufacture that dongle whatsoever.

The key is interpreted by the dongle. So if he has the wrong dongle, it will produce strange keypresses.

I have a ticket open about this problem where you instructed me to post in this thread. Should I continue this there or start a new ticket?

Sorry – I advised you to post in the remote keymap thread so we could look in to this. But you do not have the correct receiver so this will never work.

I don’t understand how this can be the case because we haven’t manufactured that dongle before.
We can send you a new dongle. Please mention this on the ticket and I will get it out for you on Monday.


Some bug on my rp 3b+

As your not even using the same hardware it is not likely your issue is related. I would recommend starting a new thread with a description of your issue. You might try another power supply or seeing if a fresh install on your SD card works first though.