OSMC's May update is here - OSMC

We hope that you had a good Easter.

We are introducing a final update to our existing Kodi v19.5 release to improve stability and give users that wish to stay on this version of Kodi for some time an improved stable and supported platform.


This is a companion discussion topic for the original entry at https://osmc.tv/2023/05/osmcs-may-update-is-here-4/
5 Likes

Version is May 2023 2025.01-1 (on Raspberry Pi).

Thank you for the update.
Just installed the update, everything went smooth and no issues so far.

Made a donation, to show my appreciation for all the work you guys put in OSMC.

2 Likes

Thank you for the continuous support! Looking forward to the next major update :slight_smile:

After updating my wifi is broken. I can find the network but it is failing when I try to connect.
Already tried to forget the network and start fresh. And I tried via SSH and connman (I get an Input/Output error there).

I’m using a Vero 4k.

Log is here

Edit:

I just figured out a temporary solution. My Wi-Fi was encrypted with WPA3 with fallback to WPA2. Switching it to just WPA2 let me reconnect my Vero 4k to my Wi-Fi.

Not the solution I want for the future, but at least it works for now.

on my side… raspberry pi2 apparently there’s no difference after this update.
from kodi.log:

Info sul kodi.log:
2023-05-04 22:15:42.586 T:387      INFO <general>: Starting Kodi (19.5). Platform: Linux ARM (Thumb) 32-bit
2023-05-04 22:15:42.586 T:387      INFO <general>: Using Release Kodi x32
2023-05-04 22:15:42.586 T:387      INFO <general>: Kodi compiled 2022-12-26 by GCC 10.2.1 for Linux ARM (Thumb) 32-bit version 5.10.78 (330318)

Info VERSION_ID:
VERSION_ID="2023.01-1"

this update it’s not include raspberry side?

The update is for all supported platforms, including Pi 2.

I believe there is a typo in this commit.
Shouldn’t it be VERSION_ID=“2023.05-1”?

Indeed, thanks for pointing that out. Will resolve.

Should be fixed now – still awaiting new laptop so some workflows are ‘manual’ which led to a couple of typos :slight_smile:

Will also re-spin the images so they reflect the correct version.

1 Like

i have retry to check update right now.
received a base-files-osmc package and updated it.

need to reboot my pi2 to see if all now result completely updated.

edit
so… this is my result of ‘sudo apt-get update && sudo apt-get -y -f dist-upgrade’ from ssh:

Hit:1 http://security.debian.org bullseye-security InRelease
Hit:2 http://ftp.debian.org/debian bullseye InRelease
Hit:3 http://ftp.debian.org/debian bullseye-updates InRelease
Hit:5 https://www.deb-multimedia.org bullseye InRelease
Hit:4 https://ftp.fau.de/osmc/osmc/apt bullseye InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.                              osmc@osmc:~$

now apparently it’s the result extract from kodi.log:

osmc@osmc:~$ version

Info sul kodi.log:
2023-05-05 12:15:36.418 T:374      INFO <general>: Starting Kodi (19.5). Platform: Linux ARM (Thumb) 32-bit
2023-05-05 12:15:36.418 T:374      INFO <general>: Using Release Kodi x32
2023-05-05 12:15:36.418 T:374      INFO <general>: Kodi compiled 2022-12-26 by GCC 10.2.1 for Linux ARM (Thumb) 32-bit version 5.10.78 (330318)

Info VERSION_ID:
VERSION_ID="2023.05-1"
osmc@osmc:~$

i hope now it’s all correct and upgraded :wink:

W-Fi is falling to connect to my WPA3 network after update on my Vero 4k.

WPA3 is not supported. Are you saying it worked before?

See here: No Wifi connection since May update - #6 by apo86

Doubt that’s possible.

ConnMan was actually updated in January if I recall and we didn’t have reports then, so the issue may be caused by a Debian update to wpa-supplicant.

After updating, all PVR client plugins are gone. It seems as if the relevant add-on repository disappeared.

Please open a separate thread and post logs. I have only one PVR plugin but it’s fine after the upgrade.

  • Fix BD 3D ISO freezing issue on Vero 4K / 4K +

:pray::pray::pray::pray:

1 Like

They are installed automatically and don’t come from a repository. You just need to enable the one you want.

Best

Sam

It wasn’t tested?