OSMC's October update is here with Debian Buster and Kodi 18.8 - OSMC

I´m glad to this. If I can help you with any testing, logs etc. please let me known. I will be happy to repair this very good feature.
Thanks
Jan

Hi Guys,
Quick question… I am running a Vero4k+, however when I look for any update there is nothing available?
I am on June 2020 (2020.06-1)

Should the new version be updateable from the unit ?
Or do I have to download an image or some such and stick it on a thumbdrive??

Cheers
Steve

Not sure what was going on, but just checked the website this morning and can now see the Vero 4K image as listed. Thanks!

1 Like

Yes, would be automatic update. You can manually check under MyOSMC - Update.
If manual check also doesn’t work I suggest to upload logs via MyOSMC so that we can check.

Thanks for the prompt reply.

I was using MyOSMC - Update and it was blank (Been trying for a couple of days now).

Went back in an hour or so after posting my enquiry and as if by magic it was there and available !
Update is now complete and everything seems fine.

Cheers
Steve

1 Like

Please find the solution to this here…

Update ran perfectly on two devices. Nice work :sunglasses:

1 Like

That issue should now be resolved and the images are available on the site and via the installers.

This installer now uses our 4.9 kernel so that we can also get some more testing. The OSMC system itself still uses our 3.14 kernel however.

1 Like

Update ran perfectly 3/4 RPIs. One said it couldn’t install. Reformatted SD card and did clean install and backup of settings -all good now. Seems a tad faster than old version

The update went perfect on my raspberry pi 3. I have quite some additional packages installed, but everything went still very smooth.

Thanks for all the great work!

Hey guys!
Are you intending to release an update with Kodi 18.9?
I have been facing problems with a lot of addons, including weather, IPTV, etc, and I have discovered Cloudfare made major changes on their services and a lot of addons simply doesn’t work anymore.
Kodi Team released 18.9 update to allow users keep using Kodi after the “disaster” caused by Cloudfare at Kodi users.

I hope you can release an update as soon as possible so we can keep using OSMC :slight_smile:

Regards!
Guilherme

Our Kodi v18.8 already has the CloudFlare fixes backported. If things aren’t working, this won’t be the issue.

I’ll do an 18.9 release for cosmetic purposes soon enough.

1 Like

Oh… so I’m no lucky person…

I’m facing problems with last OSMC (raspberry pi1) running Leia 18.8… I have just ran a fresh osmc install and it’s still facing problems with Cloudfare :frowning:

On my laptop running Ubuntu, Kodi 18.8 wasn’t working either, but after upgrading to 18.9, this get fixed…

Well, I’ll start to pray and hope Gods could help me lol :smiley:

  1. How do you know it’s a problem with Cloudflare?
  2. Have you updated the “fresh OSMC install” to pick up any recent changes?
  3. You can wait for 18.9 to appear or provide debug logs of your current system so we can try to find what the problem might be.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

In fact it’s working. The backport mentioned by another guy before your reply is indeed working! I was collecting some evidences, but it’s not necessary anymore!

Thanks a lot for your attention and detailed instructions about how to collect debugging information.

:slight_smile:

1 Like

You’ll need to purge the packages and then make sure iptables-legacy is the default using the legacy commands here: nftables - Debian Wiki

Some commands will error as they aren’t used, like arptables

Once done, try installing the iptables-persistent package again

While enabling iptables-legacy is necessary, is there a reason why you also suggest that the packages should be purged and reinstalled?

purging may not be necessary, but i like to clear out anything that could cause an issue. in my case i’d already purged before setting the legacy packages as active, so it may well work without purging and just doing a dpkg-reconfigure instead.

Thanks for update! The UI got smoother for one

Did the HLG support make it to this update?

HLG support comes when we release Linux 4.9 to the stable repository.

2 Likes