OSMC's October update is here with Debian Buster and Kodi 18.8 - OSMC


You had installed the 4.9 Kernel earlier but didn’t followed the updates in that testing thread.
Change deb http://apt.osmc.tv videoimprovevero main to deb http://apt.osmc.tv videoimprovevero49 main and update again

Many thanks!

I have changed the sources.list. How can i start the update via command line? I cant access the osmc menu.

sudo apt-get update
sudo apt-get dist-upgrade

My system is running again. Your support ist really perfect - thank you!!!

1 Like

I can confirm this behavior, if you have CEC set to turn off your TV on kodi shutdown. It turns off your TV when updates are started, because kodi is then shut down…
But I don’t think this is a bug as such, as it does exactly what it is set to do…
But it would be nice if, for example MyOSMC would temporarily disable this setting when an update is started… if that is even possible?

CEC is however behaving difficult, already for a long time for me.
When I press a key in kodi when everything is turned off: Receiver switches on, TV switches on…then when the TV is almost ready, everything is switched back off… and then on again very quickly sometimes so quick that the TV was still ‘shutting down’ and apparently misses the new CEC ON command …(some times this repeats 2 or 3 times). When I then finally get an image on the TV, the receiver suddenly switches to TV audio-input instead of OSMC-input. I have to manually switch CEC (which I do using Yatse) to have the receiver tune back to OSMC-input… and that also repeats itself 2 or 3 time before it finally steadies in the state as it should be so I can actually use Kodi. Both of these phenomenons don’t occur every time. some times only the switching on/off, some times only the input-switching, some times both, some times none of these…

But I have the impression that it got worse since this update…I didn’t experience the ‘none to these’ yet since the update.
And a subsequent problem I now have, since this update. Whenever I’m watching something else beside OSMC (for ex. satellite box). And I’m finished, turn off the TV, which triggers a CEC OFF on the receiver and satellite box. Then suddenly everything switches back on, tuned on OSMC (now always without turning off/on/off/on or receiver switching to TV audio)… And this keeps repeating when I again turn off the TV. this only stops when I let everything switch off by turning OSMC to Standby mode … then everything is turned off by OSMC and stays off…

However once upon a time, when I did not yet have an OSMC Vero 4k, but a custom PC with CEC adapter, it all just worked… It even also just worked initially (04/2017) on my OSMC Vero 4k … But after certain updates, it started to behave more and more like what I now described…
Never actually bothered to report it here, as it was not as bad as now, and I could live with it…
My satellite box also has some CEC issues (forces receiver input back to itself whenever input is changed, and never turns on or off the receiver, only the TV),… so I was used to it up to a certain degree…
But now it is starting to get a bit too annoying…

But maybe I should start a separate topic for this?

Maybe, but I would suggest reviewing your CEC settings in Kodi and your AVR. You probably only want to have Kodi set for turning your TV on and off (not TV and AVR) and additional settings for changing sources or power should probably be set to ignore or pause playback. It sounds like you have more than one device trying to control power state and unfortunately it seems that most CEC capable devices use power toggle instead of explicit on/off commands. The trick seems to be to only issue power on/off to your TV and allow your TV to turn your AVR on/off. Also you don’t want your AVR to dictate power state of connected devices (ie when you power off your AVR it sends a power toggle which may turn devices on instead of off).

I have problem booting after upgrade to new version - after installation and reboot I saw only black screen. I think that something went wrong and completely reinstall system. On clean system I´m continue with installation of @joakim_s X11 simple desktop.
After installation of this I can´t find in Program Addons X11 launcher and after reboot I saw again black screen. It is possible to connect to RPi over SSH and I have these logs: https://paste.osmc.tv/doluzeyuwe
After some time when I move with mouse I saw this picture

When I tried

sudo reboot

actual session was closed but raspberry not restarted
After unpluging of power I saw again the black screen and these logs: https://paste.osmc.tv/uxewokosep
Strange is, when I testing this [TESTING] Debian 10 Buster
all working good, but after official update i have these problems.
Anybody have same problems?
I known that X11 simple desktop is for stretch, but I dońt known why is broken also booting and how to uninstall simple desktop or fix this problem.
Thanks for help

HI Sam & co,

Just wondering if the new Vero 4K image is available on the Download site? Looking to do a clean install, I can see the link on the download page but it says ‘md5 not found’ and clicking the link says ‘Not Found’.

Thanks heaps!

I made clean install over pinn / Noobs . Now I have kodi 18.8

I will look into this, on vero4k to begin with, the son has inherited my pi3 for coding purposes.

I´m glad to this. If I can help you with any testing, logs etc. please let me known. I will be happy to repair this very good feature.

Hi Guys,
Quick question… I am running a Vero4k+, however when I look for any update there is nothing available?
I am on June 2020 (2020.06-1)

Should the new version be updateable from the unit ?
Or do I have to download an image or some such and stick it on a thumbdrive??


Not sure what was going on, but just checked the website this morning and can now see the Vero 4K image as listed. Thanks!

1 Like

Yes, would be automatic update. You can manually check under MyOSMC - Update.
If manual check also doesn’t work I suggest to upload logs via MyOSMC so that we can check.

Thanks for the prompt reply.

I was using MyOSMC - Update and it was blank (Been trying for a couple of days now).

Went back in an hour or so after posting my enquiry and as if by magic it was there and available !
Update is now complete and everything seems fine.


1 Like

Please find the solution to this here…

Update ran perfectly on two devices. Nice work :sunglasses:

1 Like

That issue should now be resolved and the images are available on the site and via the installers.

This installer now uses our 4.9 kernel so that we can also get some more testing. The OSMC system itself still uses our 3.14 kernel however.

1 Like

Update ran perfectly 3/4 RPIs. One said it couldn’t install. Reformatted SD card and did clean install and backup of settings -all good now. Seems a tad faster than old version