OSMC's October update lands with Kodi 15.2

Originally published at: OSMC’s October update lands with Kodi 15.2 - OSMC
Hi everyone This month we have again been working on core OSMC improvements. We’re currently working on Bluetooth audio support, automated filesystem checking and repair, the OSMC desktop and Apple TV 1st generation support. As some have noticed, Vero has been out of stock for a few weeks. We are now working on a new…

All that stuff just in the October release? Wow, that’s impressive!

One question on one of the changes…

Reduce Raspberry Pi 2 overclock parameters for turbo profile to ensure better stability

Are the overclock parameters read and set at boot time or are they persistent once set, i.e. do I need to re-apply the turbo profile via settings to get the new parameters applied or will a simple reboot do it?

Hi Julian,

Raspberry Pi 2’s sdram_freq was 500Mhz on the Turbo profile, and this has proven to be a little too aggressive. We have noticed that a lot of users reporting filesystem corruption had this profile enabled. We’ve backed this down to 450Mhz.

When upgrading, OSMC will automatically reduce this setting accordingly, and after a reboot, which you will be prompted to perform, the new setting will be used. If your Pi was stable at the higher frequency, then you can adjust it back manually in My OSMC -> Pi Config -> Pi Overclock.

Sam

Done the update. Thanks a lot Sam.

I get a error, unknow packages . Then it reboots

Please start a new thread with a debug log so we can explore the problem.

Sam

Never mind :slight_smile: It works now. Don’t know why but after i did get the update again all works great …

Thanks Sam, runs fine

Newest (OSMC_TGT_rbp2_20151025.img) OSMC disk image installed with:

dd bs=4M if=OSMC_TGT_rbp2_20151025.img of=/dev/sdb

fails at installation with message: “install failed: could not mount bootfs”.

I’ve tried to reformat sdcard twice and result is still the same. Looks like broken image. I can’t use your official installer, because it doesn’t work on Fedora (Broken Osmc-installer RPM packages for Fedora / CentOS - #6 by dmissud).

Hi

I haven’t published this image yet – where did you get it from?

Please stick with official images at osmc.tv/download/images. You should only use images published on this webpage, as they are the only verified images.

EDIT: I see you did it by browsing our directory listing. That’s never a good idea – I test a lot of things :smile:

Sam

Hi Sam. How does the hotfix work? After you put in the code and click done on the on screen keyboard, what should you see? Do I just leave it and wait? How long do I wait? I tried it, waited a few minutes and nothing happened, so I thought maybe I needed to reboot to get it going, but that did nothing as well.

Thanks

Hi

We are currently seeing a very high amount of traffic on our servers, so things may be delayed. Your device should reboot after the hotfix is applied.

You should be able to just reboot, go to My OSMC -> Updater -> Manual controls -> and select Check for updates now.

Sam

So, just to be clear :
1-enter the hotfix code
2-there is no visual feedback whatsoever to suggest a download or install
3-it will eventually reboot
4-I’ll be able to update without an add on error being produced after this

Hi

Don’t worry too much about the reboot. Just manually reboot and head in to the updater and try it now. Let me know if you have any problems

Sam

Official image for September (20150929) is empty (0 bytes). I’ve downloaded “unofficial” (20150928) and it works.

For which platform? Please start a new thread if this is a persistent problem.

The 20150928 image has issues that will prevent proper updating

Sam

RPi 2 - look for yourself

I’ve pulled that mirror for now as it’s buckled under the update demand. Have also reverted to August 2015 as latest until I can verify your report.

Sam

What do You mean? After configuration and 2 reboots I’ve run an update which has just finished and uname -r shows now: 4.2.3-2-osmc, so I guess it updated properly.

We don’t recommend you install images that are not linked from the web site download page - because they are test and pre-release images not suitable for public use. There are issues with the updater in the version that you downloaded - just because it worked for you the one time you updated doesn’t mean that it works properly.

There is currently an issue with the download images for the October release so until we have that resolved it is recommended that you install the previous official September release from the download page and update to get to the October release.