OSMC's September update

Originally published at: OSMC’s September update - OSMC
Hi everyone, In this month’s update, we’ve been working hard on some core OSMC improvements. We’re preparing for the launch of a new web browser and support for more hardware. In this release, we have included all fixes from the soon to be released Kodi 15.2. We have also worked on improving update and download…


That looks like a lot of good stuff - well done for cramming it all in.
Am off to try an update.

1 Like

Fantastic work as always Sam! :smile:

1 Like

Thank you. :grinning:

After updating I am getting these error messages when trying to play a movie/tv show via nfs:

18:30:18 459.722809 T:1547113504   DEBUG: Loading: libnfs.so.4
18:30:18 459.723969 T:1547113504   ERROR: Unable to load libnfs.so.4, reason: libnfs.so.4: cannot open shared object file: No such file or directory
18:30:18 459.724213 T:1547113504   DEBUG: Dll libnfs.so.4 was not found in path
18:30:18 459.724518 T:1547113504   ERROR: NFS: Error loading libnfs (HandleDyLoad).
18:30:18 459.724762 T:1547113504   DEBUG: SECTION:LoadDLL(libnfs.so.4)
18:30:18 459.727264 T:1547113504   DEBUG: Loading: libnfs.so.4
18:30:18 459.728149 T:1547113504   ERROR: Unable to load libnfs.so.4, reason: libnfs.so.4: cannot open shared object file: No such file or directory
18:30:18 459.728516 T:1547113504   DEBUG: Dll libnfs.so.4 was not found in path

It seams like libnfs was upgraded during the update today.


Go to My OSMC -> Updates -> Scan for manual updates now and update again.

It should then work again. Please let me know how you get on. It may take a few minutes for the update to become available to your regional mirror


I did an manual update right away, because I disabled auto updating. Just tried it again but it shows that there isn’t an update available for me now. I am on version OSMC September 2015 2015.09-1 as stated in the My OSMC App.

Would it be okay to just install libnfs4 via apt-get ?

No. OSMC uses its own libNFS library with various improvements over the upstream Jessie one. Doing this will cause problems with future updates

Update servers synchronise on the hour, so it should become available in about 10 minutes or so.



how retrieve the OSMC version using SSH ?

Thanks for the fast support. Will try again in 10 minutes and report back.

cat /etc/os-release

so fast ^^

Tks :wink:

Updated 2 RPi - including one with official display.
Went fine.
Takes a bit getting used to the touch display but works well.

1 Like

Allow logging in to emergency shell without a password

I assume/hope that would only be the case if no root password is set, or?

Before there used to be a password prompt, even if there was no root password, i.e. the account was disabled.

Now we don’t offer that prompt and just allow access to the recovery shell. Remember that this is only presented when the system cannot boot properly and only provides access to those with physical access (not over the Network), so we consider this secure


Other points to keep in mind besides those mentioned by Sam are:

  1. We previously (for a few months) had a recovery console activated by holding shift during boot that took you directly to a root prompt regardless of any passwords. (This stopped working due to a recent kernel update adversely affecting detection of the key being held down during early boot, even though the recovery console code is still there)

  2. Anyone with physical access can remove the SD card and mount it on another Linux PC, or edit cmdline.txt on any PC to add ‘init=/bin/bash’ which will also boot directly to a root shell without any password and regardless of whether a root password is set. (This is pretty standard on any Linux distribution - if you have physical access you can edit the kernel command line to include init=/bin/bash allowing you to boot directly to a root prompt without a password)

As no root password is set by default in OSMC, without this change, 99.9% of OSMC users will not be able to log in as root if the system boots automatically to the recovery console, making it very difficult to repair the system now that shift for recovery console no longer works, so we believe this is an acceptable compromise especially when the emergency console only triggers if the system is unable to boot properly.

@DBMandrake, @sam_nazarko

I agree the physical access point is valid argument and it is more of mindset topic

Would you expect this to support the Edimax 7711 series of adapters? I see the note about the 7811 and am guessing the 7711 probably needs different code.

Depends on the chipset used in that device. If you have it at hand, try it.


Check for updates manually gives a osmc addon error,had to reboot the RPI by connecting through SSH

 sudo reboot

After rebooting the update went smoothly :osmc: