Pair PS3 Controller

How can i pair my ps3 controller via bluetooth? I’m using the latest osmc build for raspberry pi 3.

osmc finds and i can use the controller with usb fine, but i don’t see anything in the bluetooth > discovery column.

anyone?

You could try pairing it via the CLI with bluetoothctl

i have no idea what that means can you be more specific?

Hi,

You will need access to the command line:

https://osmc.tv/wiki/general/accessing-the-command-line/

DBMandrake posted some instructions for pairing via the command line:

Thanks Tom.

tried that

osmc@osmc:~$ bluetoothctl
[NEW] Controller B8:27:EB:9E:DC:BF osmc [default]
[bluetooth]# scan on
Discovery started
[CHG] Controller B8:27:EB:9E:DC:BF Discovering: yes
[bluetooth]# pair B8:27:EB:9E:DC:BF
Device B8:27:EB:9E:DC:BF not available
[bluetooth]#

did i do it wrong?

Hi,

Just found this:

This may help

Thanks Tom.

i already tried that before and it doesn’t work for me.

Hi,

So it isn’t listed under peripherals as the topic suggests?

Thanks Tom.

only when its connected via usb

Hi,

Are you trying to use the controller for kodi or retroosmc?

Thanks Tom.

the osmc media player.

Hi,

From googling this appears to be a kodi issue, looks like it may have become an issue with krypton. It may be worth asking the question over at the kodi forums (when it comes back up)

It me worth trying when connected via usb pressing the PS button, disconnecting; it may become visible,

Sorry I couldn’t be more helpful.

Thanks Tom

but i have no problems pairing it on libreelec which is using the latest kodi.

Hi,

Weired it was the libelec forum I checked, which seemed to state it was still an issue.

Have you tried the PS and disconnect?

Have you ssh access, I was wondering if you could try connecting via the commandline again and provide a screenshot of the output?

Thanks Tom.

yes it doesn’t do anything.

i already posted that a few posts ago?

Hi,

You could try via hci:

sudo hciconfig hci0 up

hcitool cc B8:27:EB:9E:DC:BF

Thanks Tom.

osmc@osmc:~$ sudo hciconfig hci0 up
osmc@osmc:~$ hcitool cc B8:27:EB:9E:DC:BF
Can’t create connection: Operation not permitted

Hi,

Sorry:

sudo hcitool cc B8:27:EB:9E:DC:BF

Thanks Tom.

osmc@osmc:~$ sudo hcitool cc B8:27:EB:9E:DC:BF
Can’t create connection: Input/output error