Password to SMB/LAN resources appears invalid after OSMC update

After a very long time of running OSMC and avoiding installing updates for fear of repeating previous experiences of problems after updating, I decided to install the updates that were reported to be on offer.
Although the updates seemed to be installed without error, I now find I cannot access any of my media, music/films/videos/pictures, which are held on another machine but which has been previously accessible to the OSMC machine without issues. The updated version of OSMC is KODI 16.1 dated October 29th 2016.

  • Lan and Internet connections are reported to be connected; all of my network is fully up and running, so this issue is clearly with OSMC following the update;
  • Although the music/film thumbnails are shown as usual, the media files do not run, as OSMC reports that the item is no longer available, and that it cannot connect to the network server.
    Attempting to access or create a new share fails because, after entering a username, the password entered is ignored.

It seems to me that updating OSMC has thrown away the previously working LAN access functions. I am at a loss as to what is wrong or how to correct it. Any ideas please.

Kenneth Spencer

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

OK, ActionA, I will append the kodi.log file as requested, and here is the problem, more explicitly:

SETUP
KODI is on a Rasberry Pi version 2, model B (node4). I have 8 RPis altogether, my other version 2 model B is a file server (node2) with 4TB of storage - the server is working perfectly.

Kodi on node4 can see the shares on the server node2. It just cannot access the files (i.e. it cannot drill down into the directories containing the files) and expects a password which previously worked but which the new version does not seem capable of accepting.
I must say that KODI is an excellent product, and I am very grateful to Sam etc for the work put into it. It is a pity that this update does not work!

THE ISSUE

  1. Everything was working correctly and had been for months and months.
  2. I accepted the invitation to install available updates.
  3. The updates seemed to be installed without error.
  4. When I try to access any media files (music/videos/films) the access fails, with the report that the item is no longer available.
  5. The "Lock Access … " screen which appears displays the username, but does not retain any password typed in and thus does not restore access.
  6. (A possibly separate little random “bugette” also occurs whereby the first * character of the password entered is not deletable - no need to worry about that at present.)

It just seems to me as though the updated KODI has forgotten the password to remote shares on the server node2. I would happily remove the offending updates and revert to the previous version, but there seems not to be a method of doing that.

Here is the log file:
kodi.log.pdf (2.3 MB)

I do hope that satisfies your requirement.

Kenneth Spencer

Please provide a full set of logs (using the osmc pastebin if you can) as we need logs other to diagnose network issues, not just a kodi log.

Also, please (as per the post linked above) reboot, do as little as possible to replicate the issue and then upload the log, this will make the log much shorter and easier to read.

Which samba server (version) do you have running on the server and what’s in your smb.conf?

Just a thought, how long did you leave it before the most recent update? There were significant samba authentication changes in April and a relatively recent Windows update changed samba sharing again. Have you searched the forum here for your issue and tried the previous solutions?

Hello fz and yk.

  1. I have posted the logs via the remote option. Let me know if you didn’t receive them - I have no idea where it went as the option is just to send to the remote site.

  2. My previous version of KODI was OSMC_TGT_rbp2_20151129.
    So, regarding your request for my Samba version, are you saying that KODI 16.1 may not be compatible with versions of Samba which were fine for my previous version of KODI stated above?
    I assume that you want details of Samba on my server (node2) if so which settings in smb.conf are you interested in? I do not wish to publicise my entire server setup! The server serves many purposes, not just as a repository for media files.

Remember: my installation of KODI worked perfectly until I installed the updates. Perhaps we should try to establish whether to updates did not install properly, or whether there is an odd error lurking somewhere. I would also like to know whether updates can be uninstalled.

Thanks for your help.

Kenneth Spencer

He probably got the Windows 10 Anniversary update, which broke Samba compatibility quite badly.

You upgraded from OSMC 29-11-2015 to 29-10-2016 in one go?

There hsve been two major changes in that time:

  1. Samba implementation in OSMC changed in April 2016.

  2. Windows 10 anniversary update broke Samba as @sam_nazarko said.

There are many threads in this forum in and around April this year with the solutions, using the search function should enable you to regain access.

It is always best to upgrade each month, that way everyone in the community can help each other through issues at the same time.

Thanks yk.

As I mentioned in the previous post, the files are not on a Windows PC, they are on different RPi2B, running Raspbian (Debian Linux v7.11 with Samba v3.6.6). Although I do have a couple of Windows 10 machines (including with the Anniversary Update), surely that is nothing to do with the SMB Shares issue, as the Windows PCs are often not switched on, but the problem persists.

I have tried a couple of suggestions which I found in some posts on the subject (including using hostname\username (and hostname/username) instead of just the username but that doesn’t work either. I’ll try hostIP\username when I get the chance. I will also search for other possible solutions.

Thanks

Kenneth Spencer

If the two RPis are running different versions of SMB you may still have the issues that happened in April which centered around permissions changes.

If you could post a complete set of log files as per the post linked by @fzinken and also the contents of your smb.conf file on the machine which is the server then we can investigate in more detail for you.

Thanks, yk.

Here is the smb.conf file as per the RPiV2B (PDC-SRV node2) which holds the media data files.
smb.conf.zip (1.3 KB)

I will post the full logs tomorrow, as at the moment I have reverted to the November 2015 release of OSMC so that I can continue to use it. I wasn’t able to locate any previous posts or answers which solved the issue, but I will re-institute the problematic latest release and get the logs, and investigate further. Not being able to resolve this is embarrassing: I built my first computer in 1978 (soldered 2,500 joints, designed & etched boards etc), have written and sold dozens of commercial programs (in C) built massive databases (Oracle/SQL Server), been an independent IT consultant for 20 years and can’t configure a Raspberry Pi as a media centre!

Best wishes,

Ken

You should upload the config on our official Pastebin. No one is really keen on downloading ZIP files.

It’s probably better to stay more up to date on OSMC releases, that way you are in for less of a ‘shock’ when you update a year later. I’m guessing it’s a case of if it ain’t broke that left things for so long, but eventually everyone tries to update :slight_smile:, so it’s better to do it as updates are released.

I’m chuffed that our update system allowed you to install 11 months of updates without any apt problems.

Sam

Don’t be ashamed - samba is unfortunately more of a “black art” than something which follows any kind of logic. :slight_smile:

Reading your smb.conf file, you have a rather complex Samba setup too, which won’t make troubleshooting any easier, but will make the process much more interesting.

Before we go any further, can I clarify that RPiV2B(PDC-SRVnode2) is your Samba PDC and your OSMC installation is on another Pi accessing data from this device as a client? Also are you mounting these shares on your media centre Pi in /etc/fstab as CIFS file systems or adding to kodi using the GUI?

If you are currently using the GUI then, especially given the complexity of your Samba installation, you may have better results mounting the shares in /etc/fstab although that won’t work if your library currently refers to the samba paths.

It would be interesting to see the log files and see whether kodi is is simply not sending the password or whether the credentials are being rejected by the server. You might also want to check the contents of both /home/osmc/.kodi/userdata/sources.xml and /home/osmc/.kodi/userdata/passwords.xml and verify that they contain the correct details for your shares.

I would suggest if you can, cloning your OSMC installation to a spare SD card so that you can use one for testing with all the updates installed and leave one on the Nov 2015 version so that you can use it until we get this sorted. That way you won’t encounter possible problems from repeating the upgrade/regression process.

This is the issue to which I was referring:

https://discourse.osmc.tv/t/samba-access-from-rp-not-working-anymore-smbclient-works/19309

It may be worth a look depending on the way you have authentication set up.

http://xbmc-commander.com/page2/page9/page9.html

See the bottom but about network shares, I had to create a password.xml file in userdata and manually add the passwords there to be able to access SMB shares.

yk. Thanks for the replies.

  1. Indeed the PDC-SRV / node2 RPi 2B is the Samba PDC. It holds a variety of data accessed by several Windows PCs, and by the RPi 2B (node4) running OSMC, and by another RPi running Apache2 and hosting three websites, one site having quite a lot of video and audio relating to Virtual Pipe Organs (one of my my other hobbies!). But the PDC copes excellently with the workload, except when copying NNNGbyte files across the LAN or when people download large music video files from one of the websites.

  2. All media data files for OSMC are set up in the OSMC GUI. That is really necessary because the various media types are held in a set of directories in just one of the Samba shares (NoBackup_N).

  3. Unfortunately I was away all day today and so haven’t been able to send the log files. I am also out all day tomorrow, but on Friday I will be able to send them. I will also examine the sources.xml and the passwords.xml files and see what they offer.

  4. SNAP: I have already created a fully working OSMC on the November 2015 issue, and that is fine. It has updates disabled, so it is safe. I shall be working on the KODI 16.1 version on Friday.

  5. I shall look at the details of the post which you kindly supplied on Friday.

Thanks for your help. If you are ever in West Wiltshire (England) I’ll get you a pint of Wadworths 6X in our local pub!

Kenneth Spencer

Thanks for clarifying the details about your setup.

I look forward to seeing the logs when you have time, I’m sure we’ll get you sorted.

Regarding your last point I’ve sent you a PM.

Gavin.

All: Sorry about not yet having posted the logs - I will have more time tomorrow (Monday), and will do so then. In the meantime, some further comments:

  • using hints from the earlier posts on this issue, I have examined the passwords.xml.
    It seems to be in line with the suggestions;
  • as above I also examined sources.xml, but that seemed fine too;
  • there were changes suggested to the smb.conf file on the KODI client, but they made no difference;
  • I have been trying NFS shares in fstab (and at the command line): the share is found but the network is not accessible.

I will give more details tomorrow.

Kenneth Spencer

I have been doing a little more work on this “SMB/Security” issue this morning.
I decided to install LibreELEC and see how that behaved - the version I acquired was the same as OSMC: namely Jarvis, 16.1.
It was an interesting exercise, because once I completed the LibreELEC Settings dialogue, which includes just a limited security configuration question and username/password entry, I was able to connect with no problems, and to add all my music, videos, films and photographs. So I suspect that the little connection dialogue provides key information which in OSMC has to be added manually to the SMB configuration files.
When I work out how to start LibreELEC to a command line (it doesn’t seem to like any methods I’ve tried so far), I’ll examine the files and look at the differences between them in OSMC and LibreELEC.
When I get back onto OSMC Jarvis 16.1 this afternoon I’ll try to post the logs as promised.

Thanks chaps …

Kenneth Spencer