Permanently change terminal font size and/or type

I tried different methods to change the font size of the terminal when you exit OSMC (and press Esc when the OSMC start screen occurs)

I tried sudo dpkg-reconfigure console-setup
Then I tried to edit directly: sudo nano /etc/default/console-setup
I also tried setfont /usr/share/consolefonts/Lat15-TerminusBold32x16.psf.gz

The thing is, all attempts work temporarily, however when you exit and re-enter the terminal or reboot the Pi, the changes are gone and again I have this small and unreadable (at least on my TV) font size.

I found this:
But is this choppy approach the only one in the end, and would it at all work?

Unfortunately this is setting the font size within kodi, not the console/terminal. Also not a good idea to add ubuntu repos either.

Is the contents reverted after reboot? Sounds possibly like the sd card may have become readonly. You can check from the terminal by issuing:

touch ~/test

Restart the pi and then confirm of the file is there with:

ls ~/test

If it isn’t, then indead the sd card has become readonly. At this point I would suggest backing your settings, installing osmc to a new sd card and then restore your settings. Also you then should be able to increase the terminal font size and have it stick after a reboot.

Thanks Tom.

The test folder could be created, however all attempts mentioned above to make a font change permanent, fail: After reboot or even after re-entering the OSMC UI, all changes are gone again.
Does it work for you?


So the test file exists after reboot?

I can try and test, but please confirm if your changes to:


Still exist after a reboot?

Thanks Tom.


@timzett after some further googling, I think installing console-setup should resolve the issue you are seeing:

sudo apt-get install console-setup

Thanks Tom.

Yes, the test file still existed after reboot.
The “funny” thing is though, yes the changes in console-setup persist after reboot but with no effect. Seems like console-setup changes are being ignored - regarding the terminal at least.

Have you seen the edit to my post?

Yes, however when I try to (re)install console-setup, it says the latest version was already installed (1.164) and:
0 updated, 0 newly installed, 0 removed and 73 not updated

Did you try changing the terminal font on your system already?

Here’s a screenshot of mine.


Sorry I haven’t got a pi to test this on, on my vero4k+ console-setup wasn’t installed.

whats the out of of: which setupcon

I suspect it will be /bin/setupcon, if that is the case, please try adding:


to /etc/rc.local before the line containing exit 0 and rebooting. Are your changes retained then.

Thanks Tom.

Nope - no change.
rc.local changed (as sudo) as you requested, rebooted, font changed using setfont.
Font change then gets applied (bigger) until I close the terminal, next time it is small again.

BTW console-setup file is still the same as in my screenshot above. It seems that somehow OSMC doesn’t read the changes in console-setup at all. And it’s also not much interested in saving setfont changes.

Anyone here running OSMC on a Pi who can try to reproduce this?


Ok I’ve just worked out whats going on now, font size is being set when exiting kodi:


Sorry I didn’t realise this earlier. You can remove my suggested change to rc.local, it won’t help in this situation.

You could try adding your font settings to ~/.bashrc (create a backup first), it may override what is being set in /usr/bin/mediacenter

I’ll try and find some time to test this, won’t be till tomorrow; sorry.

Thanks Tom.

Doesn’t seem to help either:
Added the command line setfont /usr/share/consolefonts/Lat15-TerminusBold32x16.psf.gz to the file ~/.bashrcand rebooted. Terminal still shows the previous (small) front.

Maybe I should try editing /usr/bin/mediacenter directly.


I wouldn’t recommend this, also changes will be overwritten with updates.

If you are having issues with the font being to small and unreadable, wouldn’t it be easier just to use ssh?

Thanks Tom.

I need the enlarged terminal font on the very 40 inch TV where I am running OSMC.
When I exit OSMC to the terminal, with the default font it is so small that I can barely read it from a 3 metres disctance.

CC @DBMandrake - don’t we have some scaling?

Actually it’s not. There is a set_font() function which will increase the font size based on resolution but that is only executed when a dist-upgrade is being performed during boot-up, so that the blue update screen is more readable not when Kodi exits.

It could be called on Kodi exit as well, the only thing is not everyone would necessarily want the font size bigger, and the font size of the console when exiting Kodi would then be inconsistent with the boot time font size, so holding CTRL during boot and exiting Kodi would get you consoles with different font sizes.

A preference option to enable larger console fonts in general for higher resolution modes might be feasible though, taking effect during boot.

1 Like

That setfont command requires sudo (ie root privilege). Since you still need to log on to user osmc after exiting Kodi, I’d expect it to run .bashrc.

Edit: I just tried it without sudo via VNC and it picks up the new font. (I don’t have access to a TV right now.) Anyway, it seem to work over VNC.

1 Like

I wouldn’t mind getting different font sizes or all in bigger ones. I would like to have the font size (and type) in the terminal, when exiting OSMC and pressing ESC, just being the one I defined.

Same here over Putty, however after rebooting the Pi or re-entering OSMC the changes are gone.
Could you reboot and check on your TV?

I only have VNC access but it still works after reboot and after exiting Kodi multiple times. The only thing to note is that the logon screen is in the default font but one I’ve logged on the new font is used.

When I SSH in there’s an error message if I don’t use sudo with setfont, so I added it back.

So I am now wondering what might be the difference between VNC and Putty here :thinking:
I log on with the default Linux root account anyways, but whatever change I try, with or without sudo, is gone as described above.

I think I will give it a try, by changing the font function section in mediacenter, however that will take me some time since I first need to locate the actual font files OSMC uses for this.


Putty would imply you are logging in with ssh, if you login using a keyboard on the terminal screeen, does the font size increase, set font needs to be .bashrc for this to work.

If you actually need to font size to bigger in putty, you can do this under window appearance.

Just clarify, cos I seem to got confused along the way; where does the font need to be bigger? The Console screen or putty?

Thanks Tom.