Persistent "OSMC Update Error"

I leave my RPi2 RC3 device on all the time, set to automatically check for updates once a day. For the past 4 or 5 days now, whenever I turn on my TV I see an “OSMC Update Error” message. Screenshot is below.

Any ideas what is causing this? Please let me know if any output log might be useful.

Yes, logs will be useful


Use the Log Uploader function in MyOSMC and post the resulting URL here.

Just make sure all logs are ticked and that should provide all the info thats needed.

Please also enable debug mode in Kodi, attempt to perform a manual update then after the error appears use the log uploader to upload all the logs.

I was experiencing this issue with my Vero. Yesterday, finally, I was able to solve it.

After some reading in the forum, I thought it had to to with the selected skin I was using, which was Aeon Nox. Switched to OSMC, but no luck.
Then I noticed that I had the Internet connection frequently toggling from None to Occupied. So, I disabled the ethernet conection and enabled the Wireless one.

Voilá!!! After a reboot, I manually checked for an update, which was successfully applied, and after another reboot I switched again to the ethernet connection and to the Aeon Nox skin.

Hope it helps, if it is the same problem.

I just enabled Kodi debug mode, I think (Settings >> System >> Debugging >> enable). I will upload logs next time I get the error. I am not sure your idea about running manual update will work here, since manual update always works fine. Whenever I see the error, I click “OK” and then just run manually. The manual process always seems successful, without any error message windows.

This is interesting. I use Ethernet, and have no wifi dongle. I did notice in the past that the internet was listed as “no internet” or “disconnected” (something like that, anyways) under the network settings. Seemed strange, but I didn’t really think more of it. Anyways, I checked again now: internet says “connected” and there was no error on the screen this morning.

If it only seems to happen during a scheduled update, just set the schedule time to 5 minutes in the future then wait to let it happen - make sure debug mode is enabled first.

After the error occurs upload the logs. Thanks.

Error message was present when I got home again :frowning:

Here are the logs:

Thanks - the error seems to be caused by the updater failing to lock the APT cache.

This normally means that some other program is already trying to run an update or install an app - is there anything else installed on your system that might be trying to run updates or install software ?

I don’t think so, but I am not certain how to check this.

I have a pretty barebones setup - just standard OSMC and a handful of external addons (backup, global search, keymap editor). I did not see anything in those program settings that would indicate auto updating or installing software. And is it strange that this conflict would happen every single day?

I also use the OSMC backup app, set to run a backup before checking for updates. Not sure if this would cause any issues. It seems like the backup process completes successfully, because I can see a new tar.gz file at the time the backup was set. For example, update was set for 9AM, and I can see a file today: “OSMCBACKUP_2015_06_23_09_00_18.tar.gz”

If there was, that should be locking /var/lib/apt/lists/lock and we should not proceed if that’s not available, and I think we would’ve backed off the update before. Instead it seems like the schedule may be locking and then in another thread trying to obtain the lock again?


Can you try turning off the automatic backup in OSMC settings and see if the error still occurs ?

OK, I turned it off (myOSMC >> backup >> how often do you want to check >> never). I will let you know if any errors come up.

We have been able to reproduce this issue and are testing a fix.

It only occurs if automatic backups are enabled so in the meantime as a workaround you can disable automatic backups.

Specifically, it is automatic updates combined with the automatic backup at the same time.

@DBMandrake @Karnage Glad to hear it! To be clear, is it the OSMC backup feature or the separate “backup” add-on causing the conflict? (I use both.) Was the cause that backup is trying to run an app update as part of the backup process?

Its just a code fart that was causing the error. The other backup addon is all good and has nothing to do with the issue.

I have the same problem. Also with an RPi 3.
Logs are here

The problem reported in this thread a year ago has long ago been fixed, so while you might appear to have similar symptoms it will not have the same cause. The debug log you posted does not show the same problem as depicted in the original post.

What happens if you update from ssh like so ?

sudo apt-get update
sudo apt-get dist-upgrade

If this fails, please post the reported errors.

Also I notice you have added an APT repository:

deb sid main non-free

Do you still have an update error if you remove this repository ? If so it will be an issue with the repository.

He is also using ‘sid’ which is the testing repository. This will depend on newer libs than jessie has, and will cause problems in the long run.