Pi 3 config.txt - overclock settings

Hey there,

Just finished installing my brand new pi3, all is well, sd card came from pi2 and everything is up and running, updated to the latest version.

Now i noticed that in system info all was still set to 900mhz and 450 for the Ram.

Can i Just set it to 1200mhz and 900mhz for the Ram?


MyOSMC pi config module allows for setting custom overclocks.

Not after you’ve installed the latest update.

Update again. You are probably not up to date.

I’ve did a fresh install with the latest image. Then I’ve initiated a manual update and one was found and installed. After that one the custom overclocking settings in myOSMC didn’t work anymore. This was one hour ago.
With the latest image there is no problem.

Provide logs demonstrating the issue and give us a little more verbose description than “doesn’t work” please.

Looks like the config.txt is more generic and the overclock options in OSMC doesn’t make a difference if there is an Pi 2 or a Pi 3, or can’t differ

Did another check for update but it said no updates available.

Two I think from 2016.02-02 to 2016.02-03 and after it another one but that doesn’t change any number, just installed no idea what is does

Guys, without debug logs (as asked for) demonstrating the Pi overclock module not working it’s unlikely to get fixed.

So please turn on debugging, try to set your custom overclock then use the log uploader to upload logs.

I’d like to know that too! what are the default cpu, ram, etc. values for the pi3? Because right now it sets the cpu clock to 900Mhz… (with all the latest updates to osmc)

I just did a fresh install on my RPi 3 and looks like the speed is set to 900mhz. Could someone please provide the correct settings to put in the overclock section to get it to run at the normal speed?

Remove all speed settings and they will be set as default and if you are on the latest updated version and going to MyOSMC Overclock choosing “normal” and it is not doing that for you please provide debug logs.

I never changed any settings. This is a fresh install and the normal profile says it is at 900mhz. I’ll try and get debugs later this evening.

So I notice that even though under “My OSMC” the cpu seem to be set to 900 mhz at default, if you look at system info from Kodi —> hardware, the CPU speed is set at 1200 mhz (as expected). I’m going to guess that kodi 1200mhz is the correct representation of what my cpu is set at.

My Rpi3 is rocking a fresh install of OSMC.

Rocking stock here @ 1.2ghz

yes mine is on 900, 450, 450 by default. what should they be on pi 3?? in know 1200mhz but what about the next wo settings?

Either just manually delete all of them as they fall to default or just go in MyOSMC overclock and set to normal and apply that will take them out.

Unfortunately there is no preset setting in “My OSMC”

You can do is the following if you know how. I will not get into the details of how to do this.

edit config.txt
comment out/remove

and now you should be at 1200.

I’m currently running at 1450.

Sorry can you explain what you mean with that? MyOSMC has been updated to support the RPi3 and has under overclocking the “normal” values stored. So selecting “Normal” profile will remove the settings from config.txt

1 Like