Pi b crashing

Pi model B keeps crashing after the latest update. happening during browsing movies or tv shows.

is there a problem with this update?

Please refer to this discussion which looks similar to your problem…

Best is to enable debug and upload a log for the mods.
You can also try to add: dtoverlay=mmc to your /boot/config.txt and see if that fixes the problem.

If the later does … it is best to mention your SD card brand and model in the topic sunnyvk mentioned.

Already updated to 4.3.3-2 and also added dtboverlay=mmc to config.txt, but Pi keeps crashing.
Using Samsung Pro HC-1 micro SD card 16GB.

This is Pi 512MB B version.

Logs uploaded: http://paste.osmc.io/zagecesobo

Need debug logging enabled to provide more verbose info while demonstrating the crash. Also, describe the crash, is the entire system rebooting or is Kodi simply crashing and restarting?

With log level 1 in advancedsettings.xml:


error flashes on black screen and OSMC splash screen displays.
Happens consistently when browsing Movies/Tv shows/Music or any other list.

Does it drop an SSH session indicating a system reboot? Or after black screen and splash Kodi returns?

What lists? Addon lists? Library lists?

Did you capture the log file just after Kodi crashed ? It doesn’t appear so because there is nothing in the system journal to say that Kodi exited…

Can’t see anything helpful in the log you provided unfortunately.

Also, you seem to be on Amber skin. Does the same thing occur if you switch back to Confluence?

Yes it drops SSH session when it crashes.
By any list I meant, any data source you browse.

I enabled the debug setting in advancedsettings.xml, rebooted, went to movies, started browsing, it crashed, when it came backup, I uploaded the logs via OSMC log upload function.

Is there a graceful way of rolling back?

Of course not… The point of “development” is to move forward…

As I asked before, is the same behavior present in other skins besides Amber?

Yes, crashes in Confluence and OSMC skins as well.

finally got the message that flashes before OSMC screen:

waiting for root filesystem device /dev/mmcblk0p2
/dev/mmcblk0p2: recovering journal
/dev/mmcblk0p2: clean 41038/962880 files, 685197/3844352 blocks

If the SSH connection drops then it sounds like the Pi is rebooting. What overclock settings are you using and if not “normal” have you tried setting it back to normal ?

Have you tried a different power adaptor ? Spontaneous reboots especially when doing something that would cause CPU use spikes such as navigating the menus is more often than not power related.

What USB devices are powered from the Pi ?

Why is power adapter always the go to culprit? This Pi was running solid until the december update.
But in order to rule it out, I will test with different power adapter (from my other PI that has not been udpated to december udpate and is running stable). Will also set overclock to normal.

Back in 10 mins.

Different Power adapter used, still crashes.
overclock set to normal, still crashes.

No USB devices other than remote sensor.

Maybe because it is the number one cause of spontaneous reboots on a Pi by far, especially the older model B Pi ?

Maybe because we have seen the same kinds of symptoms hundreds of times before and seen the same disbelief from users that their issue could possibly be power related when it “worked fine before” only to find out in the end that it was in fact the cause ?

No it’s not always the cause but spending ages doing all kinds of software troubleshooting when the symptoms likely fit a power or overclock issue is just a waste of everyones time.

As you can see in your dmesg you are still using sdhost driver
Jan 01 11:23:17 osmc kernel: mmc0: sdhost-bcm2835 loaded - DMA enabled (>1)

Take a way the comment sign from #dtoverlay=mmc reboot and check then with dmesg | grep sdhos

Maybe because it is the number one cause of spontaneous reboots on a Pi by far, especially the older model B Pi ?

I second that.
I did all myself some months ago.
Crashing crashing crashing. WiFi and wired network working in waves.

Original power supply, not made any important changes to my B Pi. So what?

It turned out to my own disbelief that the power supply had gone bad. Still delivering some power to keep the Pi alive but failing to give enough in moments of higher demands.

Changing it did solve everything.


1 Like

I have tried both with dtoverlay=mmc and without. still crashes.
Also used different powersupply … no help either.
Set overclocking to normal… still no help.

Since this crash is happening on browsing media sources, I am going to delete them and recreate… perhaps something to do with database. (long shot but worth the try as it does not crash playing a movie).

tried deleting and recreating media sources… didn’t help.

What’s next? fresh install?