Pi b crashing

try renaming /home/osmc/.kodi to something else and then restarting. That should pinpoint if the problem is something within your Kodi configuration or not.

OMG… renaming the /home/osmc/.kodi did the trick. Such a simple fix!.. not sure what was the problem with the folder… that started only after applying the December update.

Thank you all, every time I come close to throwing this thing out the window… the community presents the solution. Gold stars for ActionA !! :smile:

So this would indicate that something in either the Kodi configuration or possibly some problematic addon that you had installed was causing an issue. Anyway, enjoy OSMC!

I’ve also got a RPi model B and I’m having this exact same issue.
It started happening after the latest updates.

I done a clean install, changed some settings, and after a while the issue creeped up again.
The only way I can make the system stay more or less stable (though it still happens) is remove my external disk before boot so OSMC can’t scan the libraries (I’ve got scan on boot).

It happens with Amber skin and with the OSMC skin, both are installed.
I can try installing everything again except the Amber skin and see if it’s anything it adds.

Here’s a paste of my logs and configs: http://paste.osmc.io/ukivagujer

EDIT: I’ve tried using the dtoverlay option to no avail.
The logs before the crash aren’t captured.

I’m going to try renaming my kodi folder and re-doing my settings (without installing Amber) and see if that has any impact.

EDIT: Deleted .kodi, rebooted, added debugging, rebooted, added media, system rebooted by itself soon after. http://paste.osmc.io/hudesopixa

My first suggestion is to remove your overclocking, that definitely could be a reason for your crashes.
Also how is your power supply?
It is important that your device receives a stable and sufficient power supply. This may be the problem if you see a multi-coloured square in the corner of the display. Not having a good PSU can cause many problems with your Raspberry Pi; including but not limited to random freezes or glitches, unexpected network dropouts, randomly seeing external drives unmount and remount (caused by dips in power), repeat remote presses. If you are experiencing these problems, please ensure your power supply is sufficient, and don’t be offended when we ask you to do so.

I’ve tried with and without the overclocking, different power supplies used for my two raspberry pis (B rev1 currently with my folks and rev2 sitting under my TV).
This is a setup I’ve been using for years.
As stated by irobot in his previous posts, this only started happening after the latest update.
As soon as any library interaction is initiated, the whole thing reboots.
The only thing in the logs is a few lines of �������.

Well if you have taken out all overclocking and overvoltage and you are confident about your power supply the only last resort is that the SD card is dying or got corrupted

I’m sorry but I have a hard time believing the hardware is at fault after an update has been applied.
I’m going to try downgrading the kernel using the method described here and I’ll check it out when I get home for lunch.
I’ve already rebooted successfully to the previous kernel.

osmc@YuuBMC:~$ uname -a && uptime Linux YuuBMC 4.3.0-10-osmc #1 PREEMPT Sun Nov 29 17:03:54 UTC 2015 armv6l GNU/Linux 11:11:17 up 7 min, 1 user, load average: 0,14, 0,18, 0,13