Pi Zero

Will OSMC run on the pi zero?

Should be atleast, since it uses the same chip as the RPi1 :grinning:

It does run OSMC, although the lack of usb/network options means it needs some care.
If TV has CEC you can play videos from sdcard without any extra equipment and use CEC for remote control.
You could add a usb thumb drive for easier content access.
You could add a wifi dongle for proper network access. That wouldn’t need CEC as a smartphone remote is possible. (A little tricky to set up the wifi though).
And of course you can add a USB hub with a USB ethernet dongle for full Pi1 capability.

You could use the wifi pre-seeding option in the OSMC installer to pre-configure the wifi connection - provided the adaptor is plugged in during first boot and the network is available, in most cases this will work.

hi Guys!

I just ordered the pi zero for OSMC, do you have any recommendation for the wifi dongle? I saw in another topic the wifi bridge option, but would like to use a dedicated, stable dongle.

Do you have any recommendation?

Thank you in advance.

I ran it without networking just to try it out - using a RPI B image - and it worked fine (including HDMI CEC).
Need to get a micro usb adapter to try it with WiFi - but as said earlier … no reason why it should not work.

I was thinking of using it for music only by adding a USB sound card and streaming to it wirelessly. However, given that there is only one (micro) USB for data, I might be better off with a regular pi.

Unless… Sound can be taken from the hdmi to an audio jack, but I don’t know anything about that. Now off to google.

Connect a USB hub and then put your USB devices on that. Should be fine.

Using Win32DiskImager I put this weeks Raspbian Jessie image on an 8 Gbyte card and it worked fine in a Zero. I then downloaded the OSMC October 2015 RPi1 image and again used Win32DiskImager to put that on the same card. The Zero did not boot. Got the repeating 8 flashes of the ACT LED which I believe signifies that the RAM is not recognised.

I took another 8 Gbyte card and wrote Raspbian to it. Again the Zero worked fine even when overclocked to 1 GHz. Then I used the OSMC installer on a Win7 PC, selecting the October 2015 version for RPi1 to write that same second micro-SD card. Again it will not boot the Zero, instead giving the repeating 8 flashes of the LED.

Following a suggestion on the raspberrypi forum I replaced all files in the FAT partition except kernel.img with those from the working Raspbian Jessie. Now the card does begin to boot and reaches the pale blue screen with OSMC in large white letters. However it stops there with “Install failed: unsupported device”. Below that, what looks like a progress bar is fully white from end to end.

I have 2 RPi Bs since June 2012, a B+ and a RPi2. I have 4500 posts on the raspberrypi forum. So I am no NOOB making a simple mistake.

The RAM chip on the Zero is marked Elpida.

Would be good to have an “official” raspberry pi zero image as well.

Try making a new SD (with MicroSD in it) on RPI B … and put it through the OSMC update process … the take out that micro SD and put in the the Zero.
My guess is that firmware updates comes down via the update process and it more recent than installed by regular installer.
I really did have it working on Zero just by swapping over Micro SD from a SD carrier in old RPi B.


I used the OSMC installer again to put the October 2015 RPi1 version on one of the 8 Gbyte cards. Put the card in the Zero and verified the repeating 8 flashes and no boot.

I then put that card in a B+ with no network connection - no ethernet cable, no Wi-Fi dongle. Powered up and watched it boot to the blue background with OSMC in white. However it also said “Installing files” and the white progress bar filling from left to right with a dark blue. It finished that, displaying “successfully installed” (or something similar). I went through the setup procedure (skipping networking) to the “Power” menu and shutdown.

I then put the card in the Zero and applied power. Soon the blue OSMC screen appeared and all seems to be working as it should.

So something got “updated” while running in the B+ but it didn’t come in from the internet. It must have already been somewhere in the original failed installation.


Probably firmware. The installer is probably using an older firmware version.

1 Like

Have a look for a Hat soundcard? They should still work. One email showed a soundcard the same size as the Zero (although that is now lost under the pile of black friday emails I got yesterday)

1 Like

Just tried latest installer on Pi0 and I get 8 flashes on ACT light on power up.
Am going to try copying over firmware from elsewhere and see if it helps,

The OSMC update out tomorrow will be optimised for the Pi Zero, I recommend you wait for that.


The installer is currently offering 2015.10-1 as the latest.

The installer needs to be updated, should get done today.