PI1 January Update Woes (A frustrating sequel to December Update Woes)

I had major issues with bone-stock December update, which after much mucking around was related to that new SSD driver, and was addressed with dtoverlay=mmc to /boot/config.txt which appeared to work for subsequent weeks (of little use). (PI1 December Update Woes)

However after seeing a new update in January and letting it run the same behaviour is back again, ie ‘OSMC Setting Service Failed To Launch’ and My OSMC missing all its icons etc, + general errors on boot.

Logs are at:

So again, a stock install with nothing special going on. config.txt still seems to have flags as per before.

Deeply annoying…

Your latest APT entry is End-Date: 2016-01-24 16:27:08 which was before the January update. So if you updated on 24th it would mean you just updated some minor corrections that came out after december release.

Overall I have the fear that your SD card is corrupted as there seems to be files damaged on the osmc addons.
you may want to try an upgrade from the command line but depedning on the SD card I am not sure how successful you will be
sudo apt-get update && sudo apt-get dist-upgrade
If all goes thru reboot.

What happened to the ElementTree? That’s the root cause of your problem. Both the skin and the addon require that module.

ImportError: No module named xml.etree.ElementTree

Good question - whatever the update on 2016-01-24 16:27:08 was what borked things… I can go through the whole process of reinstalling and reconfiguring everything, but that’s less fun when the issue isn’t diagnosed yet.

I can not see any other “issue” than a corrupted SD card which either is a result of it getting corrupted by the sdhost driver in december or just a bogus card.
So if you want to do yourself a favour I would recommend to get a new card and do a plain installation on that.

Hmmm, but this card has worked flawlessly for a couple of years with no problems :frowning:

But it worked fine yesterday.


You have not installed the January update. According to the blog post the January update was released on the 29th of January. The last APT dist-upgrade in your log file is from January the 24th:

Start-Date: 2016-01-24  16:11:45
Commandline: apt-get -o APT::Status-Fd=4 -o APT::Keep-Fds::=5 -o APT::Keep-Fds::=6 -f -y dist-upgrade
Install: rbp1-image-4.3.3-3-osmc:armhf (3, automatic)
Upgrade: libldb1:armhf (1.1.17-2, 1.1.17-2+deb8u1), openssh-sftp-server:armhf (6.7p1-5, 6.7p1-5+deb8u1), libpng12-0:armhf (1.2.50-2+deb8u1, 1.2.50-2+deb8u2), sudo:armhf (1.8.10p3-1+deb8u2, 1.8.10p3-1+deb8u3), openssh-server:armhf (6.7p1-5, 6.7p1-5+deb8u1), libisccc90:armhf (9.9.5.dfsg-9+deb8u4, 9.9.5.dfsg-9+deb8u5), samba-common:armhf (4.1.17+dfsg-2, 4.1.17+dfsg-2+deb8u1), libisc95:armhf (9.9.5.dfsg-9+deb8u4, 9.9.5.dfsg-9+deb8u5), libbind9-90:armhf (9.9.5.dfsg-9+deb8u4, 9.9.5.dfsg-9+deb8u5), perl-base:armhf (5.20.2-3+deb8u1, 5.20.2-3+deb8u2), libdns100:armhf (9.9.5.dfsg-9+deb8u4, 9.9.5.dfsg-9+deb8u5), libsmbclient:armhf (4.1.17+dfsg-2, 4.1.17+dfsg-2+deb8u1), mediacenter-addon-osmc:armhf (3.0.524, 3.0.546), liblwres90:armhf (9.9.5.dfsg-9+deb8u4, 9.9.5.dfsg-9+deb8u5), openssh-client:armhf (6.7p1-5, 6.7p1-5+deb8u1), libisccfg90:armhf (9.9.5.dfsg-9+deb8u4, 9.9.5.dfsg-9+deb8u5), samba-libs:armhf (4.1.17+dfsg-2, 4.1.17+dfsg-2+deb8u1), bind9-host:armhf (9.9.5.dfsg-9+deb8u4, 9.9.5.dfsg-9+deb8u5), base-files-osmc:armhf (1.7.2, 1.7.9), libwbclient0:armhf (4.1.17+dfsg-2, 4.1.17+dfsg-2+deb8u1), rbp1-kernel-osmc:armhf (2.0.4, 2.0.5)
End-Date: 2016-01-24  16:26:01

The “update” you did install consisted of a solitary bug fix update to the My OSMC addon, and the rest of the update you received was all Debian related updates not specific to OSMC, as there was a Debian point release released not long ago.

I do see one thing of interest in your log other than the error Karnage already pointed out:

Running depmod.
depmod: ERROR: failed to load symbols from /lib/modules/4.3.3-3-osmc/kernel/drivers/media/usb/dvb-usb/dvb-usb-pctv452e.ko: Exec format error

This is an unusual error but suggests file system corruption has occurred at some point on your system. Possibly as a result of the period of time you were running the sdhost driver in early December, but it’s hard to know.

So since you are not actually running the January update, try updating again and let us know what happens. Because of that element tree error you may not be able to do so via My OSMC, so instead try:

sudo apt-get update
sudo apt-get -f dist-upgrade

Report any errors here.

We’re sorry that the software that you got for free written by people working in their spare time doesn’t quite live up to your expectations and doesn’t work perfectly for every one of the 600,000+ users using it… :wink:

1 Like

Thanks for your help - for December I had done a complete format and reinstall with the dtoverlay=mmc and was in the clear so by corruption are you thinking damage to the media itself?

I just did a command-line update (and still have the issues) and gathered new logs here

And yes, I too have (and still do) contribute to OS projects and appreciate your efforts on OSMC - my annoyance wasn’t directed at you or anyone at all really, it was merely a reflection on the surprising instability I’m experiencing after a significant period of time with rock-solid use - with no strong clues yet.

If I could figure out the solution it wouldn’t be anywhere near as annoying. :slight_smile:

I’ll try another SD card

I believe that will be the best path forward. Try a good Sandisk or Samsung card

The update seemed to go through OK according to the log, but the element tree issue remains. @Karnage can probably correct me but I suspect that module is bundled in the built in python interpreter in Kodi, which would mean that Kodi has somehow got corrupted during the most recent update that included a Kodi update.

You could try the following to do a forced reinstall of Kodi: (Pi 1 only below)

sudo apt-get install rbp1-mediacenter-osmc --reinstall

(The screen will go black) Then reboot from the command line when finished.

If that fixes the My OSMC error that would confirm that the Kodi install got corrupted, but if so it leaves open the question of why and how that happened - in theory it shouldn’t be possible because dpkg does checksums on files as it extracts them.

I’ve just been informed that element tree comes in the addon package, so its actually that which needs to be reinstalled. So try:

sudo apt-get install mediacenter-addon-osmc --reinstall

Then reboot when finished.