Pi2 with OSMC keeps randomly rebooting

Earlier on today, my TV kept turning itself on, set to the OSMC input.
After messing around with it I realized that what was happening was that the RPi2 (with OSMC installed) has been randomly restarting - even when it is doing nothing - which was turning on the TV.
It seems to happen randomly, in pretty much any screen - whether the unit is in use or not.

Here are a couple of logs I’ve uploaded (hopefully they will shed some light as OSMC is pretty much useless to me right now)

Logs removed cos they share too much info

Thanks in advance for any help y’all can provide.

One of the add-ons you have installed is shown as the last entry in the log files which indicate it being the reason for your issue.
That addon can not be supported on this forum, but I suggest you to disable those add-ons and see if it solves your issue.
To get a better idea of our piracy policy, please see this link here FAQ - OSMC Forums

Thanks for your advice, I’ll try that & report back.

So I disabled pretty much every questionable add-on and I’m still getting these reboots with the same frequency - which is all the time
It doesn’t matter if the box is working hard or doing nothing.
Also I tried pulling the plug on it for a while, to see if that would help. But it didn’t.
Anyone have any other suggestions?

Here’s a recent log after the mass disabling of add ons:
Logs removed cos they share too much info

Which screensaver are you using?
Maybe try to disable screensaving completely for testing

I’m just using the ‘dim’ mode - I’ve just turned it off.
I’ll report back with another log if it still is happening.
Thanks fzinken!

So I turned off the screensaver completely but I’m still getting a reboot in less than every 10 minutes.

Logs removed cos they share too much info

I’d appreciate any further suggestions.

Enable debug logging which might give a better picture of what is going wrong.
But to be honest with all those repositories on there I still believe one of them is the culprit

Good points.
I have enabled the debug logging & disabled all repositories except the Kodi one.
Currently waiting for first reboot to happen - if it does I’ll post my logs
Just passed the 15 minute mark (which is a good sign)
I’m off to bed, I’ll check it in the morning & report back
Thanks again for your help fzinken

Aaargh! got up this morning and it’s reset a couple of times already.
its lasting a little longer, but not much.

Logs removed cos they share too much info

Thanks again for any insights you can provide.

All the repositories are still enabled!

Other than that I can not see a reason for a crash.

How do you power the pi?

That’s strange.
I definitely disabled them in settings > addons
I’m out right now but will recheck when I get home.
For power I use a 2.1A power source but have a 2.5A one arriving tomorrow so I’ll switch it out for that one and see.

Yeah I checked my repositories & they’re all disabled - except for ‘popcornmix addons’ which doesn’t seem to give me an option to disable (or even uninstall) - only ‘update’.

Ok let’s wait for that, because without any errors in the logs the crash must be really sudden

OK mate. will do.
Just watched the Pi reboot twice in a few minutes - all while not in use

Logs removed cos they share too much info

I plugged the power supply directly into the wall yesterday just in case my powerstrip was the issue but still the same.

I’ll report back once the new 2.5A power supply is here.

So, I plugged in the new power supply & its been almost 3 hours without rebooting…
during which time my daughter watched 3 of her shows streamed from NAS over SMB

lets hope that was the issue!!

I never turn the Pi off, it is always on in the background.

1 Like

That would be great, so please keep us informed

It’s worked all day yesterday and has not restarted overnight (uptime currently approaching 19 hours) so I’m guessing that was the issue. Unless I post again here, let’s consider this one SOLVED! Thanks for all your help on this.

Ok, good info. Just wondering did you with the old power supply ever saw the under voltage warning (rainbow square top right corner)?

No, I have heard about it but I’ve never seen that.
Maybe it was on the fritz in a more fundamental way?!?