Pink screen


#1

Hello,

I started getting a pink screen when I turn things on. I am going mad trying to figure out what it is! I’ve tried to switch HDMI cables, I’ve tried to plug them into different ports on my receiver and projector, I’ve tried to power things off and on, I’ve tried to turn off CEC on the projector and on OSMC, but I cannot figure out what it is!

The projector is fine, if I switch its HDMI inputs to the xbox, its not pink.

If I reboot the vero4k, I see the blue startup screen, not pink! But then it switches to pink again.

Sometimes, things are not pink, but when they are pink, I cannot seem to get them to not be pink… I just try a few days later and maybe pink, maybe not. I’ve tried to isolate the variable that makes it do that, but I cannot. I’m keeping OSMC up-to-date, and I’ve attached logs here: http://paste.osmc.tv/yuhafihobe


#2

Try enabling Force RGB under Settings -> Display.
Then reboot

Sam


#3

Set that, and rebooted, but it still went pink :frowning:


#4

Any other device between Vero and PJ? I experience the same here using a video processor that has approx. 15 seconds Boottime. What helped here is to switch to a different input of the VP at boot and switch to the correct input only after it has completely booted.

Sometimes happens during playing a movie and again, switching the inputs on the VP fixes it.


#5

Does it behave if you plug vero into the PJ direct? Please post logs for that.


#6

Guess you replied to me @grahamh : I am fine the way it is. Guess it will not happen when directly connecting the Vero to the display (no PJ in my case) . The VP is an old crystalio 2 which is just so good at scaling to FHD to leave it out. It has some edid issues though which might cause some handshake problems as well. But I am fine with that


#7

If you upload a log connected directly to projector vs connected to the video processor, we can probably work out what’s going on and fix it.


#8

It does appear to work if I connect directly to the projector. That seems to suggest the HDMI-E (HDMI over ethernet) extender device I have that is in-between things is somehow screwing it up. It was working fine for a year, so its surprising that it just now stopped working. I kind of need that thing, because the projector positioning !


#9

Oddly the EDID advertises a preferred mode of 1080i.

====================== Display Cap =================== g0gjk991
480p60hz
576p50hz
720p60hz
1080i60hz*
1080p60hz
720p50hz
1080i50hz
1080p50hz


#10

1080i is set in the OSMC settings for the resolution.

Why is it odd that it is advertising that? Isn’t that just interlaced, versus progressive? Is progressive “better”?


#11

It’s odd that it is the preferred mode.
My guess would’ve been that the receiver advertises support for YPbPr but only supports RGB; but if Force RGB and a reboot doesn’t help, then something else may be the issue.

Can you try and upload a log when it isn’t pink vs when it is, so we can see what’s happening?


#12

In order to upload a log of when it isn’t pink, I’ll need to remove the HDMIE device in the middle, and have the HDMI go directly between the vero4k, my receiver and the projector, so it would eliminate one piece of the hardware, if that is ok, I’m happy to do it:

https://paste.osmc.tv/xakelivami

In this configuration, Vero -> receiver -> projector, and its normal color. I can also plug the vero straight into the projector, and get a log, if that is helpful.


#13

Do I understand that if the HDMIE device is not present, you never receive the pink screen?

Sam


#14

It appears that way. Although in order to remove the HDMIE device, I need to Frankenstein things quite a bit just to plug them in, so I have only tested a couple times, and have not tried to use it that way for periods of time (the projector has to be very close to the wall, leading to a very small screen, and the cables are hanging quite precariously due to where all the pieces are).


#15

So without the HDMI/cat5 converters (if that’s what you mean by HDMI over ethernet)? Someone else had something similar (and issues) but I can’t find it right now.

Your EDID was definately getting mangled with those adapters.

Edit: have a look here: [SOLVED] Only black screen on new Vero 4K+ never GUI


#16

Yes, that is what I meant. I read that other thread, maybe it is the same issue. Strange that we both had this happen around the same time. Could there have been an update that caused it, like the CEC firmware?

I know its possible to override EDID on the Vero, would it be worthwhile to try this to see what happens? It could be the extender can’t handle it, I have no idea.

On another note, I did search around quite a bit and found a lot of people on other forums having similar issues, for them the solution was disabling CEC. I did try to disable CEC on the projector and the Vero. The projector is pretty easy to disable, but it seems like the option changed on the Vero and I wasn’t really sure I was disabling it there properly.


#17

I ordered a new HDMI extender today, one with EDID copying, as worked in the other thread, but it wont arrive for some days.

Tonight, I turned the projector on, and weirdly… its working now.

Should I grab a log of it working through the extender? Would that be useful?


#18

Sure at least you could see if the advertised mode matches


#19

I turned it off before I got your reply, and when I turned it back on, it was pink again… I couldn’t get it to go to normal again to get that reading.

In the meantime, I got this replacement device:

which advertises that it has EDID copy function. I plugged it in, and the display is normal. So I suspect that this was the cause.