PINN image

@d22b It is true - SSH not working - also not working on original SD card. I will prepare new image, because on my previous image SSH working. I already install script for X11 simple desktop

@dillthedog MyOSMC >Logging menu was not working for me from beginning of my tests this image - over SSH grab logs working, but if not working SSH :frowning:
Also not working 5GHz wifi - I can see it, but cannot connect.
After making of new image I will send some logs.

Jan

Thanks Jan!

Ok, so SSH is broken on the PINN image? Not an OSMC issue. Good luck.

@d22b Here is a new image. Sorry for this inconvenience.
Please use button Reinstall , test this image and let me know in case other problems.
For me is SSH working now. I will also test my image in next few days.
Jan

Edit: Image is now already updated to Kodi 19.1, but I don´t know hot to setup initial setting of region, skin, language etc. So it is necessary to adjust manually.

Thanks for sharing. Now wifi doesnt work but ssh works perfekt :rofl:

It is possibe to share an “untouched” osmc image? I think something is going weird while you change something inside.

Unfortunately i am currently unable to reach sams test repo.

2,4 GHz wifi working good for me. Only 5 GHz I have problem. You have problem with both bands?
This problem is also on “untouched” image - does not depend PINN
For wifi may be help this [TESTING] Kodi v19 builds for Raspberry Pi 2/3/4 - #243 by fzinken
(Country with capital letter)
I will try prepare " untouched" image again and better.
:see_no_evil:
Test repo? You mean that not working installation of Samba, TVH etc. from Store?

Hi,

crda works for me. Now I am able to connect via WiFi.

Here is the new PINN version of initial Sam Nazarko image for Pi4 with Kodi 19.0
For me working all what I tested excluded 5 Ghz wifi - installation of crda not help, but I have all my Pi wired, so this is not big problem for me.
Please test it
Jan

Thanks. I will test the image. In my case, with crda 5g WiFi is working but 2.4g don’t.

So……
I’ve testet the Image in different setups and get different results for connectivity. In short, please try the following procedure:

  • connect the raspy only wired
  • use the last image that you have provided
  • make a fresh install
  • finish the walkthrough (name, ssh, regional settings)
  • do not(!) change the keyboard layout

then

  • do not(!) enable wifi
  • download the latest update from sam via update scheduler
  • reboot
  • do not(!) enable wifi
  • connect via ssh and apply the crda fix, use capital letter for region code (in my case DE for germany
  • reboot
  • enable WiFi now, you should now be able to connect to 2.4ghz as well to 5ghz
  • disable wired adapter

With this procedure actually now everything is working fine for me. Give it a try!

Hello
So I´m happy, that you have now all working, unfortunatelly for me after your setup still 5 Ghz wifi not working.
@fzinken advise sudo iw reg set CZ working (no error and correct result for get command), but not help in my case. Maybe the problem is CZ wifi zone. (but adjustment of DE also not help)
Here is logs from my previous setup
http://paste.osmc.tv/uposaqiyok

and here is log from last setup
http://paste.osmc.tv/enukuqoros
Problematic network SSID is “pf-JanS_5G”
in last case when I select disconnect 2.4 GHz network before connecting 5GHz I saw sad face.

You should set the zone permanently in /etc/default/crda. Then reboot.

AFAIK, all EU country codes should have the same effect, so CZ should be fine.

I think, that problem is different that wrong zone
Zone is setup correctly:

osmc@osmc:~$ sudo iw reg get
global
country CZ: DFS-ETSI
        (2400 - 2483 @ 40), (N/A, 20), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
        (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
        (5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

osmc@osmc:~$

Perhaps, but it’s still worth setting it properly.

Of course. I set it up and no change - 5GHz still no working

Which channel is that one on?
Also is your problem to see it or to connect to it. If just the connection is the problem I suggest to try from command line instead of via MyOSMC.

Hello
Usually I have adjusted “Auto”, but situation is same even if I set channel 36.
I have not problem to see the network - only if I try to connect to this network I see in top right corner

“Wireless
Connection to pf-JanS_5G failed”

In status I see “No wireless connection”
Last log right after this error is here: http://paste.osmc.tv/etidotuwur

Thanks
Jan

Suggest to try connecting via Command Line instead of MyOSMC.

In Commandline start connmanctl and execute the following:

agent on
scan wifi
services
connect SERVICENAME

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

Hello
After some test I finally connect to 5 Ghz Wifi, but speed was very low.

osmc@osmc:~$ connmanctl
Error getting VPN connections: Rejected send message, 2 matched rules; type=“method_call”, sender=":1.30" (uid=1000 pid=709 comm="connmanctl ") interface="net.connman.vpn.Manageconnmanctl> agent on
Agent registered
connmanctl> scan wifi
Scan completed for wifi
connmanctl> services
*AO Wired ethernet_dca6320eb736_cable
*A pf-JanS wifi_dca6320eb738_70662d4a616e53_managed_psk
pf-klivie wifi_dca6320eb738_70662d6b6c69766965_managed_psk
pf-JanS_5G wifi_dca6320eb738_70662d4a616e535f3547_managed_psk
Valtera wifi_dca6320eb738_56616c74657261_managed_psk
pf-klivie_5G wifi_dca6320eb738_70662d6b6c697669655f3547_managed_psk
Valtera_5G wifi_dca6320eb738_56616c746572615f3547_managed_psk
net-vychod wifi_dca6320eb738_6e65742d767963686f64_managed_none
Martina wifi_dca6320eb738_4d617274696e61_managed_psk
Vodafone Internet wifi_dca6320eb738_566f6461666f6e6520496e7465726e6574_managed_psk
DIRECT-CD-HP DeskJet 4530 series wifi_dca6320eb738_4449524543542d43442d4850204465736b4a6574203435333020736572696573_managed_psk
pf-mom, click here for internet wifi_dca6320eb738_70662d6d6f6d2c20636c69636b206865726520666f7220696e7465726e6574_managed_psk
marie@bok.net wifi_dca6320eb738_6d6172696540626f6b2e6e6574_managed_psk
netis_2.4G_32642A wifi_dca6320eb738_6e657469735f322e34475f333236343241_managed_psk
connmanctl> connect wifi_dca6320eb738_70662d4a616e53_managed_psk
Connected wifi_dca6320eb738_70662d4a616e53_managed_psk
connmanctl> disconnect
Error ‘disconnect’: Invalid argument
connmanctl> disconnect wifi_dca6320eb738_70662d4a616e53_managed_psk
Disconnected wifi_dca6320eb738_70662d4a616e53_managed_psk
connmanctl> connect wifi_dca6320eb738_70662d4a616e535f3547_managed_psk
Agent RequestInput wifi_dca6320eb738_70662d4a616e535f3547_managed_psk
Passphrase = [ Type=psk, Requirement=mandatory, Alternates=[ WPS ] ]
WPS = [ Type=wpspin, Requirement=alternate ]
Passphrase? xxxxxxxxx
Connected wifi_dca6320eb738_70662d4a616e535f3547_managed_psk

After restart when I try to connect I recieved this error:

osmc@osmc:~$ connmanctl
Error getting VPN connections: Rejected send message, 2 matched rules; type=“method_call”, sender=":1.33" (uid=1000 pid=811 comm="connmanctl ") interface="net.connman.vpn.Manageconnmanctl> agent on
Agent registered
connmanctl> scan wifi
Scan completed for wifi
connmanctl> services
*AO Wired ethernet_dca6320eb736_cable
*A pf-JanS wifi_dca6320eb738_70662d4a616e53_managed_psk
*A pf-JanS_5G wifi_dca6320eb738_70662d4a616e535f3547_managed_psk
pf-klivie wifi_dca6320eb738_70662d6b6c69766965_managed_psk
Valtera wifi_dca6320eb738_56616c74657261_managed_psk
pf-klivie_5G wifi_dca6320eb738_70662d6b6c697669655f3547_managed_psk
connmanctl> connect wifi_dca6320eb738_70662d4a616e535f3547_managed_psk
Agent ReportError wifi_dca6320eb738_70662d4a616e535f3547_managed_psk
connect-failed
Agent request cancelled by ConnMan
Error /net/connman/service/wifi_dca6320eb738_70662d4a616e535f3547_managed_psk: Operation aborted
connmanctl>

Logs: https://paste.osmc.tv/mifilahozi
O second attempt the pasword was not asked - I think it is already saved?
Thanks
Jan

We have seen that before, the Pi4 Wifi has not the greatest performance.
Check with wavemon the wifi quality and with iperf3 the actual throughput.