Pixel Shifting, SD resolution, standalone video processor for upscaling

Hm, I have previously experimented with the whitelist function (using a standalone video processor for scaling) and set it up as described here a few weeks ago but I still have the same minor annoyance I had when I first tested it:

Everything up from 720p works absolutely flawless but SD material (50Hz in my case) makes the image slightly shift a few pixels every few seconds and than jumps back to its original position.

Has anybody else experienced this or knows a way to get rid of this behaviour?

Never seen that but please start a new thread as it’s off-topic.

@grahamh I am not exactly sure it is off-topic as it only occurs when whitelisting with the goal of outputting as native as possible. If I let vero4k do the scaling and output at fixed resolution/Hz everything works fine beside scaling not being the best.

If you still think it is unrelated just let me know and I will open a separate thread :wink:

I also feel this should be split from the original thread … but let’s decide @angry.sardine how to proceed from, here.

Since you’re using an external scaling processor, it’s hard to decide whether this “pixel shifting” using 50 Hz SD material is caused inside or outside the Vero:

  • Can you reproduce this without the external scaling device?
  • Can you provide a short video example for reproduction?
  • Have you seen this thread which sounds similar?

If you set the GUI to 576p and get the same result as letting the whitelist pick that resolution then IMVHO your issue has nothing to do with whitelisting. If you’re saying there is a difference then it might take a long thread to sort it out, so I would still think it not appropriate for a HowTo.

1 Like

The thread you mention sounds exactly as what I am experiencing, did not know it though - sadly enough.

You are right most likely + I did not know the thread mentioned. I agree it has nothing to do with the Guide itself and will try the possible solution from the other thread first…

I split the communication to this new topic, feel free to adapt the title to better match your need.

1 Like

Might be worth trying to add a small amount of overscan - worked for me, and also the user in this post: Picture jumps in native resolution / external upscaling

I did set zoom to 1.01 now which is not optimal but seems to fix the jumping. The Video Processor itself does not seem to be the problem because other sources outputting SD natively work as expected.

Reading a bit further I found a note that the shifting most likely only occurs on interlaced material, but afaik my streaming provider uses 576p so I guess it is not limited to interlaced.

What is your setting for Player->Display 4:3 videos as? If it’s set to Use HDMI AVI signalling then setting zoom to 1.01 effectively turns that option off. Try setting it to Normal (but then you will get scaling and pillarboxing).