"Play disc" sometimes doesn't appear while disc can be played

Hi all.

I’ve been having this issue randomly but more than 50% of the time: I have a USB DVD player/writer that I attach to the media box (Vero2). It happens about 50% of the time (intuitively, I haven’t measured accurately) that the menu item “Play disc” doesn’t appear but when I browse and click the VOB*_ files on the drive Kodi actually plays them. I suspect there’s no hardware issue but a software glitch, just don’t know where exactly. I’d say it’s somehow related with Kodi’s “System.HasMediaDVD” function.

For the record, I have tried various removable DVD drives (Samsung, LG, Mercedes Benz, …) The one that was most successful is a Bluray/DVD player/writer from Mercedes Benz. The issue with the “Play disc” menu item happens between ejecting/inserting DVDs as well as after the system has started. It is really a random issue.

Does anyone have an idea?


Correct me if I’m wrong, but this does seem to similar to the issue you were having back in december:

I would do a as sam reqeusted then a dmesg for when it works and when it fails.

Also enabling debugging logs may also provide more to go on for this issue, details can be found here.

Thanks Tom.

Hi Tom.

This has indeed something to do with that issue, I’d say one form of the problem and that particular form is kind of solved — to me at least. It is slightly different in that we are able to play the disc every time in this very case… provided we use a short enough cable.

The issue I described in this thread’s first post is only about the menu item that appears or not on a random basis. So it’s not really the same issue, I’d say.

As for dmesg, I need to get rid of messages about cec that flood the system log. I’ll post the log as soon as I’m ready.

Is this disc drive externally powered?

Definitely. But it’s also definitely not the problem here since the DVD plays all the time, right?

Not necessarily. The logs will give us some clues though


Just some more thoughts: given that the issue happen with all kinds of USB DVD players and that not all can be USB powered, I was tempted to rule out power issues. My reasoning is that a higher current on a DVD player/writer is needed only when writing while reading only requires a more humble amount of juice, which should fall below USB current limitation. I’ll post the logs anyways this said.

I’ve just gotten news: the Vero4K media box doesn’t seem to exhibit the problem. Are both kernels interchangeable? (I’m still working on retrieving the logs, haven’t given up.)

They are different kernels as the SoC is different. I’m not sure it’s a kernel issue

I think we have found the reason: there is a DC-to-DC power supply module that we put in cars, such as this one. Turns out to be the culprit. We’ve removed that DC-DC converter and powered the Vero box with the wall power module and the issue was gone.

I hate to have to retract my statement but, unfortunately — I didn’t take part to the tests so I had to trust what was reported to me. I did testing on my own and could not confirm the DVD issue was gone when the Vero2 box and/or DVD player was powered externally. However I strongly suspect ground loops to mess with the whole system and ground loops, believe me, there are countless of them.

What leads me to suspect ground loops is that we’ve never experienced any such issue when running all the devices with their own power supply (from mains). In such an environment all devices are isolated electrically so there are no ground loops. When put in cars, the 12V line is common to all devices and most of them have a linear instead of switched regulator. Wiring all the signal lines then closes the ground loop, which, to me is prone to injecting glitches such as what we’re observing.