Play wont work after update to nov.2020

Updated from june 2020 to nov 2020 and movies wont start to play.
Any idea what to do? Reboot dont help.

Please upload logs (via MyOSMC - Log Uploader or grab-logs -A) and share the URL.
I assume you have inconsistency in your apt sources from a testing repository.


New try: HTTPS://

Logs dont seem to upload?

That is odd. Is your network connection working?

Can you try paste-log /etc/apt/sources.list and paste-log /home/osmc/.kodi/temp/kodi.log

Sorry new to this. How do I do this?

Network is ok

Via Command Line

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

Alternatively you could try in MyOSMC - Log Uploader just choose the APT logs.

First one works, but the address must be entered in lower case.

Thanks, and another one

@ooZee thanks for pointing that out.

There seems to be a problem with our NAS access unsupported protocol('"smb) I doubt we have seen this before.

When you now have access to the command line can you do
sudo apt-get update
sudo apt-get dist-upgrade
Just to ensure there are no outstanding updates.

Ive runned them. What now?
should I run auto remove?

Where any packages additionally installed?

Yes: armv7-libass-osmc armv7-libnfs-osmc dh-python gnupg-agent libbind9-140
libcdio13 libcryptsetup4 libdevmapper-event1.02.1 libdns162 libenca0
libevent-2.0-5 libicu57 libisc160 libisccc140 libisccfg140 libiso9660-8
liblvm2app2.2 liblwres141 libncurses5 libntfs-3g871 libprocps6
libpython3.5-minimal libpython3.5-stdlib libssl1.0.2 libunistring0
libwebpmux2 python-imaging python3-distutils python3-lib2to3 python3.5
python3.5-minimal samba-common

Ok, I assume your problem still isn’t solved?

No its not working

Ok, the only info I found on Kodi Forum so far is around a Kodi 19 thread but as you are on Kodi 18 that should not be the case:

  1. Try sudo apt-get install --reinstall vero3-mediacenter-osmc

  2. Are you using username/password to access your samba share?

Been stuck on this for awhile. Should I send any commands?

  1. Yes I use username and password