Play wont work after update to nov.2020

Ok, I assume your problem still isn’t solved?

No its not working

Ok, the only info I found on Kodi Forum so far is around a Kodi 19 thread but as you are on Kodi 18 that should not be the case:

  1. Try sudo apt-get install --reinstall vero3-mediacenter-osmc

  2. Are you using username/password to access your samba share?

Been stuck on this for awhile. Should I send any commands?

  1. Yes I use username and password

That was when you ran sudo apt-get install --reinstall vero3-mediacenter-osmc?
After you executed that type reboot in your ssh session.

Yes
rebooted and still doesn’t work

Ok, may try to check more details on the SMB issues hoping that gives us an idea.

Enable Debug logging and the component specific logging on “Verbose SMB Libary” and then upload logs after trying to play a video. We just need Kodi Logs so can use grab-logs -X and share the URL.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for all components

  • enable event logging and notification event logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshots:

http://paste.osmc.tv/poyoyizivo

One thing: I have two vero4k and the other one has the same problem but play starts and after 2 seconds it stops and returnes to poster wall. On that one displaying actors and playijg trailers dont work

You have enabled debug logging but seem specific component login for SMB is missing.

What are you using as your “server”

I have a synology 1819+

What do you mean by component login is missing?
I followed your instructions.

Are you sure you have chosen “Verbose logging for the SMB library”?

Maybe not, I’ll do it again. Be right back

Hope I got it right this time:

http://paste.osmc.tv/lowajamoda

Yes, that had the respective info but still no idea what is wrong.
On your Synology how are the settings for Samba (e.g. protocol version).

I would go to settings>services>SMB client> and enable the “Mitigate MTU issues with SMBv2” option and see if that does the trick.

I updated all add-ons and the skin amber, then I enabled Mitigate MTU- and now it works.(although it takes a few seconds more for the film to start playing)
Thank you all!

Good to hear. If you can enable SMBv3 on your NAS (and possibly set Kodi SMB min/max to v3 in Settings) then you should be able to disable that option again and gain that speed back. Alternatively you could switch over to a system mount which should be even faster.

Sorry for stupid question, but can you please explain what is system mount?

The way you are setup currently Kodi is handling part of the networking tasks involved in streaming files from your network location. A system mount is where you add the network location to the underlying file system so it handles the networking entirely. To do this you would add a system mount via fstab or autofs and then add a path substitution to make Kodi use this with your current library.