"Playback failed" error


NFS doesn’t use a username and password, I think it can do so by using a third party like kerberos; so I think the guest username and password is for samba/smb.

Could you please post the output off:

ls - lah /mnt

After /mnt/Films has been mounted. Also the output of:


Thanks Tom.

osmc@osmc:~$ ifconfig
eth0: flags=-28669<UP,BROADCAST,MULTICAST,DYNAMIC> mtu 1500
ether c4:4e:ac:11:8a:69 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 3 bytes 758 (758.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 40

inet netmask broadcast
ether 00:e0:4c:0c:38:4b txqueuelen 1000 (Ethernet)
RX packets 11647 bytes 1519751 (1.4 MiB)
RX errors 0 dropped 50 overruns 0 frame 0
TX packets 3050 bytes 1103784 (1.0 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 4096
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 0 (Local Loopback)
RX packets 115 bytes 35287 (34.4 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 115 bytes 35287 (34.4 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

ls - lah… : osmc@osmc:~$ ls - lah /mnt
ls: cannot access ‘-’: No such file or directory
ls: cannot access ‘lah’: No such file or directory


Sorry typo, should have been: ls -lah /mnt

Thanks Tom.

No problem - looks like this, then:

osmc@osmc:~$ ls -lah /mnt
total 8.0K
drwxr-xr-x 3 root root 4.0K Feb 4 21:27 .
drwxr-xr-x 23 root root 4.0K Jan 10 14:33 …
d--------- 1 root root 8.6K Feb 4 21:54 Film


Ok so the nas is not passing the correct permissions, the only thing I can suggest is change the squash to: map root to admin, under Edit NFS rules on the synology. Still will be mounted read only because of the flag in the fstab entry.

Once you’ve made change reboot the vero4k.

Thanks Tom.

If you don’t want to get NFS no matter what, but you’d just like to get a FSTAB mount working quickly, it might be good to switch to SMB FSTAB mounting at this point. With SMB you can use authentication and it might still give good enough throughput (but getting rid of the hassle with NFS, if this isn’t solvable in a timely manner, which it doesn’t seem to be):

And I thought, my NAS (WD MyBook Live) was a difficult setup with NFS… It doesn’t have any GUI configuration options for NFS, everything had to be done via SSH. But it looks like it was a lot less complicated than Synology seems to make the whole setup :see_no_evil:

OK, some progress :slight_smile:

I changed the squash setting as suggested, and now I can add the share. Still no playback, though!

I will switch to smb as and see if that helps.


Before you switch to smb, please provide logs showing the no playback issue.

NFS will give better throughput

Thanks Tom.

Its not unsolvable, I’m running a synology and watching a video using nfs fstab; as I type this

I don’t want to imply that it doesn’t, just wanted to point @eriksdam to a different solution, if he’d want to choose to try something else… And if he’d not want to get NFS working at any cost. :wink:

Fair point, but it does seem we may not be fair of getting this working with nfs; just need logs from @eriksdam

Yup, ok… If @eriksdam is willing to keep trying a big longer. :+1:t2: It might give some clues for future problems and maybe even for some adjustments of the wiki entry.

1 Like

Oh, I’ll keep at it, no worries :smiley:

had a quick stab at SMB (which is what i started with before I posted here) but same issue: The files and folder themselves are found/recognised, but no playback.

I think I’ll call it a day, though, and post the logs tomorrow - thanks for your support!!!

  • Erik

Ok, so we’re stuck with having to find the culprit here no matter what… :joy: So, it’s not related to NFS only.

Do that :slightly_smiling_face: Thanks should mostly go to @Tom_Doyle. He’s the pro, I’m just trying to help where I can :wink:

1 Like

Hi Erik,

I’m sure we are not far off getting this to work, but I agree starting again tomorrow is the way forward; taking a break from things, on return the way forward often shows its self. Will review the logs, when you’ve posted them tomorrow.

Thanks Tom.

@Chillbo thanks for the compliment. I’m no pro, just trying to learn as I go and like yourself help where I can.

Protip: reboot the NAS and router before getting started back tomorrow :smiley:

1 Like

Will do :wink:

couldn’t stop myself: Log

I switched back to nfs, and behold:


Still no playback, though! Arrrrgh!

Thanks again guys, I’m sure “we” will nail this.

Hi Erik,

This can wait till tomorrow if you prefer, but I’m still about so I can follow up; it’s up to you.

“MVC.mkv (File doesn’t exist?”

It seems kodi is still having issues seeing the files, could you please issue the following command:

ls -lah /mnt/Film | paste-log

And post the link provided.

Thanks Tom.



Hi Erik,

That looks ok, have you tried restarting the NAS and router as ActionA advised? If not please do so and try playback again.

If there are still issues, please copy one of the movies you have tried to a usb stick and try playback locally on the vero4k.

Thanks Tom.