Playback problems Vero 4K+

I’ve just bought a Vero 4K+ second hand. I have a 6TB external usb drive attached. When trying to play a video it takes several minutes for it to start and during that time Vero also get unresponsive if I do too many clicks on the remote. After a while the video finally starts and plays normally, but navigation can still be slow. What’s the problem?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Is the drive externally powered?


The hdd is a brand new Seagate Backup Plus Desktop Hub USB 3.0 6TB and it works flawlessly in Windows 10. When I run “Clean database” Vero also get unresponsive or even hangs. Maybe there are errors in the file system that causes this behaviour? Or is the drive itself incompatible somehow?

We need logs as you were already advised. Without the logs it’s impossible to know what may be happening.

1 Like

Started a movie. It took several minutes as before. Noticed that CPU-KODI was over 50% and dropped when movie actually started.

Log entry:

I’d run a SMART test on that drive

How do I perform that? Recommended software?

I would generally recommend starting by scanning with manufactures tools which in your case should be found here…

Can do on the Vero.
sudo apt-get install smartmontools
You then can run with the drive connected
sudo smartctl --test=long /dev/sda

Your issues may be coming from that Diamond build you put on there.

SeaTools error checking tools and SMART check with another utility checks outs fine. Do I have “Diamond build”? Is that a beta or a unofficial version? Should I reinstall? Is Kodi 19 released yet?

Kodi v19 is not even in alpha status yet.

So a reinstall of 18.3, if it’s the latest version, is the next step? What did the log say? Anything helpful at all?

Same problem with another USB drive that’s also passes various disk checks. I copied a couple of movies to it and as with the other drive it takes minutes for a movie to start. Even a small mp4 video clip has this issue. Strange.

Can you try copy the file to the internal storage and see if the issue persists?

Ok. From another computer then? File manager doesn’t seem to have any copy option.

Started up a raspberry pi 3 and tried the two mentioned hard drives. All videos start immediately.

See Transferring and editing files - General - OSMC.

Maybe there is something unique about the files you are playing.
Try: It should play smoothly and fast