Playback Video - sound stuttering after March 5th Update

You can try a Kodi v18 build and see if it fixes it


So far so good here. Will continue to run this and will report back again later.

1 Like

Looks like that was the fix. Watched a 90 min movie with eac3 sound track and it was flawless. Great job Sam!

1 Like

So far so good @sam_nazarko
Good stuff.

1 Like

Working brilliantly. No audio glitches. Thank you so much!

A few days have gone by and still working perfectly. Very happy

Glad to hear this. Thanks for testing. This will be in the next update shortly.



This has definitely solved the issue for me. I haven’t had a dropout since I’ve run the dev update. Perfect playback here.

1 Like


Hi all.

I ask you to run further tests with differently encoded movies.
I’ve been doing some tests and getting some issues after updated to this kernel 4.14.34-5:

First - after this update there is no immediate sound stuttering when downloading a torrent at the same time - seems fine :wink:


  • I was using MMAL and after some minutes watching a movie, I get a lot of sound stuttering without even using transmission for any torrent downloading.
  • I switched to OMX, but unfortunatelly, with some movies I can only watch with passtrough enabled, as when forcing the conversion I need (3.1) some movies, stay out of central channel - going to passtrough, sometimes cut the sound completely, or hand the system. This was something I discussed in another thread and swapped at the time for MMAL which worked just fined until now.

I ask you to please do some further testing and delay the formal release of this kernel version. Meanwhile, I will try to get some mediainfos to share with you.

Unless it causes regressions, is there a reason we should delay public release?

well … as i’ve stated above without touching the system configuration, I was unabled to watch a movie with MMAL after some minutes, due to major sound stuttering - this did not happened before.

the user taiebot65
complained about the same some days ago.

So this is a regression from the kernel we shipped in July?
@taiebot65 didn’t report regressions. He just said that there was no improvement.

I don’t know if you downgraded to 4.9

I’ll postpone Pi updates in the August update accordingly.


Hi @sam_nazarko
I’ve previously downgraded to 4.9, and have been like that for quite sometime.
I’ve upgraded yesterday from 4.9 to this new dev branch 4.14.35-5

I wouldn’t say it’s a regression the. I’d just say that this kernel doesn’t give you any benefits.


Well I have to say i am noticing weird behaviour since this update.
I am using raspberry pi 2b and i use live TV with tvheadend.
I am noticing an overall drop of performance. I can see it going through menus feels much slower.

Besides what I’ve reported yesterday and the day before

I’ve just finished watching a new movie and around 10 minutes it started to get a lot of sound stuttering and also video stuttering.
After a while the sound muted completely.
Trying to stop hanged the system.

I’m also using tvheadend, and today, with this last kernel, channels simply stop and cannot get out of the player.
After some minutes I have to force a reboot or , if kodi responds, I get a blue background without the usual osmc background image.

After this, I’ve again went back to the old kernel version 4.9.29-10.
Everything fine.

Please @sam_nazarko, I don’t want to be urespectfully with your awesome work, but this last testing kernel bought new undesired issues.

I’m willing to collaborate and provide whatever tests you need.
By the way: no strange messages in the journal about these playback issues.
Will it be of any help if I try to make a new fresh install with this testing kernel and try to replicate the same issues ?

That could be useful.
Unfortunately without any logs I don’t really have any ideas.

Others have reported improvements with this new kernel.


I noticed it improved as it does not start to have immediate audio stuttering after or while using transmission.
But the stuttering comes after 10 minute of playing, independently of using transmission or not and more definite (audio stopping and also video stuttering) than before.

I’m now creating a new sd card and try to replicate the issue with a fresh system.

I haven’t encountered a single issue with playback since I’ve updated to the dev update. All of my media is mkv from rips from bluray or from amazon. They all play back flawlessly.