Playback Video - sound stuttering after March 5th Update

Just out of interest, what skin are you using on your Kodi?

The update solved my issue on my rpi 3b+. No audio glitches. Everything works perfectly. Thank you so much Sam!

I’ve made a fresh osmc install in a new sd-card in my Raspberry Pi 3.
updated it.
changed /etc/apt/sources.list in order to include stretch-devel main
updated to the testing kernel version 4.14.34-5
enabled ssh and transmission.
connect an external usb hdd which contains several test movies (the same i’ve been using with my osmc config)
went into file explorer and started to play some movies.

I confirm that this fresh install with kernel 4.14.34-5 replicates the exact same issues I was talking about in my previous messages
After roughly 11 mins of continuous playback, the video started to stutter and then the audio. Then the audio completely muted.
I was continuosly monitoring the journal with: journalctl -f
At the time , I’ve got the following error in the journal:

osmc kernel: cma: cma_alloc: alloc failed, req-size: 1 pages, ret: -16

The full log is in the following url (the name of the movie is TESTING.avi)

After downgrading to the older kernel 4.9, playing the same movies didn’t had any issue.
I’ve watched another movie with the exact same issues.
I will continue to monitor with other movies.

(I’ve tried using mediainfo to report the video parameters but it seems not to be working with files with more than 2GB. Any suggestions ?)

With ffmpeg -i I’ve geot the following summary:

Input #0, avi, from TESTING.avi:
  Duration: 01:50:07.85, start: 0.000000, bitrate: 3649 kb/s
    Stream #0:0: Video: mpeg4 (Simple Profile) (XVID / 0x44495658), yuv420p, 1280x536 [SAR 1:1 DAR 160:67], 3255 kb/s, 23.98 fps, 23.98 tbr, 23.98 tbn, 24k tbc
    Stream #0:1: Audio: ac3 ([0] [0][0] / 0x2000), 48000 Hz, 5.1(side), fltp, 384 kb/s

I have experienced audio stutters not only with movies, but as well with mp3 and flac audio playback on osmc Kodi 18 beta since March. It also happened when watching mp4 format movies, usually it starts only after a couple of minutes and then repeats every 30 to 60 seconds, with no audio for 2 seconds each time.

I have since then reviewed settings and installation of my NAS server and intranet network, switches and so on. Nothing helped to solve the issue.

I am glad that I run into this threat and can confirm that Kernel 4.9 solves the issues for me so far.


Did you try the fix?

No, because I was unsure if this was for the stable release only or as well for the beta. Thanks for your suggestion, I will definitely try to install the latest kernel and the fix and see/report if this works.

(I am usually running the most recent stable linux kernel on my computers - currently 4.18 -, but I remember that 4.9 was very stable and smooth. Shouldn’t be much difference between 4.9 and 4.14 on a rpi2 …).

Back from holidays and update available with a fix for this issue, great :slight_smile:

I tested 2h yesterday evening w/o any issue, so far so good!

Has anyone had problems with MMAL playback in OSMC 2018.08-2 (kernel 4.14.34-6-osmc) on Rpi2 ?

Yes – the problems will come back for those previously affected as the fix severely compromised performance for those that did not experience this issue.

Unfortunately there were more people negatively affected by the fix than positively affected by the fix, so a revert was in order.


Is there a way to role back to the previous OSMC 2018.08-1 update? Will be there a solution to our problem or out of options?

I have a spare rp3 b+. Would it be a possible solution if I use the spare rpi with rasbian to run the transmission daemon with the HDD and share the media over smb or nfs. If so smb or nfs would be a better solution.

Thanks in advance!

We are still looking in to this.
You can install the previous kernel, but we can’t provide support for this.


Sounds good!

I have a spare rp3 b+. Would it be a possible solution if I use the spare rpi with rasbian to run the transmission daemon with the HDD and share the media over smb or nfs. If so smb or nfs would be a better solution?

Thank you!

Yes, would be possible and nfs on linux is always the better (more performant) solution

Personally, i am very happy with this latest release.
Finally I can watch my movie library without having to use an old kernel version :wink:.

Everything seems to be stable.

Thank you for your support.

1 Like

Just tried the latest update and obviously the problem is back as read it had to be rolled back. Will continue to run the older kernel for time being. As long as there is a work around, it is what it is. :slight_smile:

1 Like

Same here … By the way, I have HifiBerry DAC. Problem occurs also with HDMI sound, but just in case … it seems that some don’t have this issue. Wonder if it may be related to a HifiBerry installed?

Currently Kodi is unusable for me. I have installed kernel 4.9 again because the patched kernel 4.14 does not longer install (???). I consider trying libreELEC or so, though. If only few have this issue (with standard hardware …) it will probably very difficult to sort this out.


Sorry, but I must review my last evaluation.
In fact, there is still some “micro” sound stuttering.
And I say “micro” because it is very subtle.
But it still happens, but only when watching a movie and making a download with transmission at the same time.

In Opposition to previous kernel versions, when transmission stops downloading, the stuttering disappears (in previous versions, for stuttering to disappear we needed to reboot the system).

Downgrading kernel back to 4.9.29, fixes this too.

About logs:
Nothing to report during the video playback in journal.
But I’ve noticed the following in kodi.log:

18:41:32.237 T:1885336320 NOTICE: CAESinkPi:AddPackets Underrun (delay:0.00 frames:2400)


An additional update:

Yesterday I was waching a tvheadend tv program previoualy recorded in an external hdd.
at the same time, another program was being recorded by tvheadend.

Sound stuttering was present like once per minute.
When the recording endend, the playback stuttering stopped.
This happened with the current kernel version.

Downgrading kernel to 4.9.29 also fixed this.

Will the October release with new kernel and raspberry firmware improve this situation? I’m still on the February release due to the audio stuttering problem.

Try it. It should do.