Playing 3D Blu-ray in 2D

Hi. Since the recent Kodi 19 update, playing stereoscopic 3D Blu-ray mkvs - which I’d like to play in 2D on my non-3D tv - results in my tv compressing the image into the bottom half of the screen. There is no mention of 3D in the file name and I have stereoscopic 3D mode disabled in settings. Never had a problem with this before the update.

Here’s the log:

Thanks for all the hard work that’s gone into this update.


Beside the fact that you’re playing Avatar and the metadata says “Life of Pi” everything looks normal to me :slight_smile: .

2021-08-09 13:28:12.981 T:3085     INFO <general>: ffmpeg[0xb348ce70X]: Input #0, matroska,webm, from '/media/Maxtor/Movies/Avatar (2009)/Avatar (2009) 1080p.bluray.mkv':
2021-08-09 13:28:12.981 T:3085     INFO <general>: ffmpeg[0xb348ce70X]:   Metadata:
2021-08-09 13:28:12.981 T:3085     INFO <general>: ffmpeg[0xb348ce70X]:     title           : Life of Pi
2021-08-09 13:28:12.981 T:3085     INFO <general>: ffmpeg[0xb348ce70X]:     encoder         : libebml v1.3.4 + libmatroska v1.4.5

According to the metadata this is not a 3D mkv, it’s a 2D one. So I wonder if you’ve attached the right log?

Hmm, that’s weird. Definitely attached the right log- it’s the only one I’ve done. I’ll check this when I’m back later and get back to you. Thanks.

Can you also check if a cold boot of your Vero solves this issue?

Cold boot didn’t help unfortunately. I’ve tried this again on my other vero, this time playing Hugo and The Hobbit from my movie library (both 3D mkvs), then both films again directly from File Manager (FYI- all movies are stored on a powered usb hard drive connected directly to vero). Same behaviour across the board. I haven’t seen anyone else mention this issue so maybe it’s a problem on my end, on both machines, so could always try a fresh osmc install if you think that may help.

I’m looking at the ‘The Hobbit’ part of the log. You’ve said that it’s a 3D mkv. But there’s neither the 3d flag set in the metadata nor there’s that “3D” in the filename. Can you do another test and add “3D” as tag in the filename and give that a try?

Hi. Sorry, I’m at my other place now so only have Hugo and Avatar to test. I added .3D to the Hugo’s file name…no joy. Very odd. Are you able to test the same scenario at your end by any chance? Other than the kodi 19 update, nothing has changed on my end and these files always played fullscreen prior to this. Thanks.

Hi, I’ve tried to reproduce it, but it’s working here. But I only have a 3D capable TV, so I had to fake your setup which might be the reason why it’s working here. Can you try a kodi default setup like it’s been described here: [TESTING] Kodi v19 builds for Vero 4K / 4K + - #842 by ActionA

Ah ok. Just tried a default setup as suggested with the same results…picture is compressed to bottom half of screen.

Can you provide a 20 sec sample of one of your 3D mkvs? If needed I can give you an upload link.

Happy to do so but will need guidance on how to do this. Thanks.

There’s no need to, because I can reproduce it now. The root cause is that your mkv files doesn’t have the ‘stereo mode’ property set. Kodi detects that it’s MVC based on some other data and tries to play it as 2D but initializes the decoder as 3D.

I need to think about that issue and how to fix it. Meanwhile, you can either rename your files and add ‘3d.mvc’ to the file name (e.g. “The Hobbit.3d.mvc.mkv”) or set the stereo mode property in the mkv file. Additonally, you should set the “Playback mode of stereoscopic 3D videos” in Kodi to “Monoscopic/2D”.

The reason why it had previously worked (and still might work) is, that when you play a video with that property set, followed by a video that hasn’t, then somehow the kernel was correctly configured from the previous one.

You see, it’s complicated and it will take me a while to find a fix for it. I hope you can live with the workaround.

Thanks for looking in to this! I have absolutely no problem using your suggested workarounds, and hope this issue is useful for you to have identified. Thanks for your time.

1 Like

That one should be fixed in the next update.

Hello, Is that have been fixed ?
Is there a way to solve it minwhile ?


I believe this was fixed some time ago.

Are you still experiencing an issue?

Hello Sam,

Yes on this post :

Unable to change resolution? - Help and Support / Vero 4K / Vero 4K + - OSMC Forums