Playing BD without navigation

I have a bluray folder I am trying to play. The log (which I will upload if really needed for this) has:

CDVDInputStreamBluray::Open - Unsupported titles found - Some titles can't be played in navigation mode

I am ok with this, but, then the player exits. I can’t get to play the main title. Since the top folder is set as as a movie folder in the kodi database, kodi/osmc will always try to “play” the folder, not letting me drill down to the STREAM folder to select the .m2ts file to play.

This is a little frustrating. A crude hack would be to just create a symlink to the right .m2ts that I could navigate to through the menus (btw: I’m using OSMC skin, if that makes any difference).

Am I missing something here? Is there a better way to play the video (without hacking into the nas filesystem)?




Without logs it is hard to tell what device you are using, OSMC or Kodi version.
So it’s unclear to me if this error is even anticipated.


Sorry it’s been awhile, but personal chores had to come first.

I uploaded logs:

Just to recap, I followed these steps:

  1. Scanned BD folder to kodi. The source folder (“bluray”) is a folder that has BDs in separate BD folders, one for each film title. You can see the settings for this source from the uploaded logs.

(Note: I have OSMC basic skin)

  1. From home menu, select Movies, then select a BD movie. I chose “Bill and Ted’s …”, as you can see from the logs. When I select that to play, the movie does not play, and nothing is shown on the screen.

  2. Again from home menu, I select Videos->Files->bluray (this is the source folder). I scroll down to the same movie as above, select it to play, and again, the movie does not play, and nothing changes on the screen.

From the kodi.log:

ERROR: CDVDInputStreamBluray::Open - Unsupported titles found - Some titles can’t be played in navigation mode
DEBUG: CBlurayCallback::Logger - bluray.c:3287: _play_title(): no menu support

That’s alright, I understand this can’t support BDs with this navigation. But, now I have no way to get to the actual .m2ts file to play - which osmc can play. That is my problem. A very ugly hack-around is to copy the appropriate file to another source folder that will handle single files as movies. Then I can navigate to that and play it.

IMO, if the player can’t handle the navigation, then kodi/osmc should show me a list of the title files (*.m2ts) from which I can select to play. Or perhaps, simply play the largest file. But at the very least, a popup should say that the title can’t be played.

So there it is. I don’t know if this is an osmc problem or a kodi problem. Maybe both? In any case (without the ugly hack) I can’t play this BD (as well as several others).

Let me know what you think.

As always, thanks.


The easiest and most elegant solution to your problem is to remux your Blu-ray to MKV. You don’t lose any quality or functionality. It just takes the video and audio files together with subtitles and everything useful from the Blu-ray structure and packs them into a .mkv file

The tool most use for the task is and its free.

Definitely not elegant, IMHO.

This would be uglier than my ugly hack-around. I would still need to move that file somewhere and have it scanned into kodi’s library (not to mention removing the old bluray folder already scanned in).

OSMC can play .m2ts files (which are the original bluray encoding) if it can find the file. That is my problem.

I just tried running kodi on my phone (Samsung S8 android). It was running v19 Matrix. This actually implented BD menus somewhat as I described above. So, if this is fixed by v19, when will osmc get upgraded to that version?

Also note that on my android phone, kodi could play most x265 files that osmc Vero 4K+ can’t handle (see this problem I had posted about earlier: Issue with Vero4k and raw 4K MTS files? - #59 by daytooner).This is with very few buffer refills, and with no stuttering. And this is over wifi to the same nfs server as with osmc. Note that I can’t run any x265 videos over wifi (from the vero). And even with hard-wired connected by gigabit ethernet, some of these still won’t play.

Of course, this does very little for me, since I really want to watch these 4K videos on my (very expensive) 4K UHD tv.

This is just some information I hope will help.


Currently there are test builds available.

just a quick note:

I upgraded/updated to kodi v19 as mentioned above.

OSMC so far works okay. Playing x265 UHD videos are now much better, but this is only via ethernet. I haven’t tried wifi yet.

Unfortunately, this version does not handle BDs quite the same. On my S8 (android) phone, when I selected a BD folder, I get options to play main title, choose a title, or attempt running the menu. osmc doesn’t give that menu, just tries to play the BD without giving any choices. At least now, I get an error message stating this BD can’t be played. So, I still can’t play those BDs (without manually moving files around).



Re-edit several hours later:

I had to add to this. After a few sad faces and then a system reboot, all the navigation stuff started working, and fairly well. Even though some BD menus won’t work, at least now I can select a title to play. And it does. Much better than ever.

kudos to all of you kodi and osmc team people. As always, a fine product.