Please Need Help With RPI And SMB

Hello everybody.
It’s days that I’m trying to set up SMB on OSMC and Raspberry PI 1 sadly with no success.

What I’m trying to achieve is to access the shared directories on my Windows 7 PC. While I can access them through UnPnP subtitles and files scraping are not available with it.

I followed the instructions in this guide with no luck so far: File sharing with a NAS, media server, windows share or other device

When I add video then explore SMB I can see my modem/router and workgroup but whenever I select WORKGROUP the “Invalid argument” error pops up.
I installed SMB2 to OSMC, SMB2 is enabled on my Win7 PC, to access the directory I’m using the same credentials of my account.

I honestly don’t know where to bang my head anymore

You need to enable SMB1 to be able to browse to the shares on Win7. Once you have added the shares to your sources, you can re-enable SMB2 or 3.

All as explained in the Wiki (I thought).

Thanks for the reply.
Which one do I need to enable SMB1 in: OSMC or Win7?

I enabled SMB1 both on OSMC and Win7 when I explore SMB I see my router and WORKGROUP, when I select it then are showed OSMC and the Win7 PC.
If I click the Win7 PC it shows me “Operation not permitted”.

Have you tried typing the share string like

smb://user:password@SERVER/sharename/folder?

Of course, user and password are those on the PC and it helps if SERVER is an IP address, not a Windows hostname.

Yes I tried that, tried with IP and with SERVERNAME.
I tried smb://user:password@192.168.1.250/SharedFolder

I tried to follow tips and instructions in every guide and thread I’ve found but still no luck.

I honestly don’t know what to do more, I’ve been trying for days and in the end asked for help here because anything I did failed.

This is so frustrating, I was thinking to start a fresh install, maybe I messed something up, I don’t know.

I like OSMC I it would allow me to add smart features to an old TV.

I suggest to try the autofs approach instead of the Kodi smb implementation.
First try to figure out if your win7 is setup correctly.

sudo apt-get install smbclient
smclient -L 193.168.1.250

And post the output

apt-get install smbclient got me: "smbclient is already the newest version (2:4.5.12+dfsg-2+deb9u4)

193.168.1.250 is it a typo? My PC’s address is 192.168.1.250

OK, I tried smbclient -L 192.168.1.250.
I got: “Protocol negotiation failed: NT_STATUS_CONNECTION_RESET”.

Try smbclient -L 192.168.1.250 -m smb3

It says: “session setup failed: NT_STATUS_LOGON_FAILURE”
Yesterday after failing to enable it I disabled smb1 on the Win7 machine but smb2 should is still there.

smbclient -L 192.168.1.250 -m smb3 -U <username>

Edit:
I get “session setup failed: NT_STATUS_INVALID_HANDLE”

Does it matter that my PC has Windows 7 Ultimate installed on it by any chance?

Shouldn’t make a difference.

I don’t know.
I re-enabled SMB1 in OSMC but whenever I try to access that or another folder I immediately get the “Connection timed out” message.

If I try to explore SMB I can see my router (which I can access flawlessly) and my PC but, who knows why, as soon as I click it the message pops up.
I’m going to reinstall OSMC and start all over again.

Edit:
Which one is the best version?

Good idea to start from ‘factory’ but TBH I doubt that’s the issue.

Connecting to a Windows share from anything but Windows is a PITA. Check carefully the permissions you have given to the share on the Windows machine. It took me ages to figure out and I still don’t know exactly what I did to make it work.

Some days it doesn’t work.

My crappy ISP providers’ modem/router comes with an USB2 port and plugging a USB key into it allows me to access the files on it through SMB, incredibly slowly but I can enjoy movies still .

I got rid of the broken network shares I’ve previously created in it.
With moderate enthusiasm restarted OSMC and still I can’t access my windows shares but I can fully access OSMC shares from my Win7 PC, it’s the other way around basically.

I couldn’t see the OSMC RPI in my network before but now I can and I haven’t the faintest idea of how it could have happened.

This is bizarre.

Maybe its a problem with January 2019 Windows Security rollout.
I had same problem.
see here
https://support.microsoft.com/de-de/help/4480970/windows-7-update-kb4480970
it locks out win7 users with local admin rights from remote access.
There is a workaround you have to install manually.
For me it fixes my problems, Osmc can access again windows shares.

Hi jsb4010,
Thanks for your kind effort, sadly it’s not it, I’ve checked the installed updates and it’s there.
Apparently I’m not able to sort this thing out even with the help of people I feel I’ve abused their kindness enough.

I’ve banged my head on this matter for days before asking for help here and as far as it is this is as good as it can get.

Thanks again.

The link KB4480970 ist the description of the Win Update which causes the problem.
If you have that installed it may makes your problems.
Have you read there and followed the fix?
Sorry I posted the German version…
her in en
https://support.microsoft.com/en-us/help/4480970/windows-7-update-kb4480970