Plex add-on not launching

I know this is Kodi related but I have got nowhere elsewhere and hoped I could get support here.
The Plex add-on won’t launch on my Vero 4K+ from the programmes list. It used to work fine and Plex client launches on all other devices.
Any help much appreciated.

Are you running the Bullseye test build?

If not logs would be needed…

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

FYI; Not running Bullseye test build.

If I reboot the OSMC device twice either with or without debug logging enabled the Plex add-on launches as expected. However once I exit it will not launch again unless I reboot twice again?
If I reboot only once the Plex add-on will not launch.
Shall I do as you instructed but only rebooting once?

That sounds similar to a bug I ran into when making the keymap for the OSMC remote. Do you happen to be exiting the Plex add-on by calling another Window (colored buttons perhaps) or basically any way other than using back/esc/previous and then choosing yes when the popup askes if you want to exit? The only thing is that your saying a single reboot doesn’t clear that condition and that doesn’t match with the bug I ran across. I can’t actually think of anything that would explain how a second reboot would act differently than the first.

Upload logs after the first reboot so we can see if there is some clue being logged. The second reboot just functions as a way to lower the size of the logs and as such is not essential.

1 Like

Hi, the plot thickens!
Plex add-on started launching after one system reboot two days ago. I have just tried it now and it launched without having to reboot.
Edit; I switched to watching a movie file via a connected HDD. When I went back to open the Plex addon, it failed to launch. So it seems that if I exit the Plex addon and switch to another activity this it what triggers the bug?
FYI: I always exit using back/esc/previous and then choosing yes when the popup asks if I want to exit.
Given the above, please advise on activity procedure required for logging.
Thankyou for your time.

Without logs it’s hard to tell what the issue is


The bug I ran into was that if Plex was open and then you called up another window from outside of the Plex add-on (such as using the colored buttons to bring up the video or music libraries) then the Plex add-on would not come back up until you rebooted Kodi. I’m pretty sure the bug is with the add-on as that is the only one I found the issue with IIRC.

Reboot, turn on debug logging, reproduce, upload logs. The idea is to just see what Kodi is logging when it is not relaunching, so upload right after that happens (preferably).

Logs will be uploaded. Been away from home since last post and may be away for 7 more days, ish.
Thanks for your patience.

Hi, sorry been totally side tracked since last post.
Okay to continue with problem solving and me to upload logs as advised?

Sure, if you still have the issue. You’ve done a clean install and are up to date now correct? Did you find the thread with the modified version of Plex since the one in the Kodi repository is not functioning correctly under Bullseye…

Do you mean a total clean install, factory re-set of the Vero?

Sorry, no. I thought I had seen you state you did a new install in another thread but I got you confused with someone else. I took a look at the log you posted in the buffering thread and the version of the Plex add-on your running is broken with the newest builds. I would recommend bringing up the information screen for the Plex add-on and select the option to remove it. When asked tell it to also remove the add-on’s user data. Once that is done install the modified add-on I linked to in my previous post and see how you get on with that.

Great, thanks. I’ll give it a try and report back.

Hi, followed your instructions to the letter for installing Plex add-on with the patch.
Still the same behaviour. Click on Plex add-on tab - Netflix style loading circle shows for 3 to 4 seconds then reverts back to add-on screen failing to load PLex.

Please upload debug enabled logs after trying to launch Plex

Shall I reboot first?

Yes, helps to keep the logfiles smaller. But reproduce opening Plex after reboot


I’m not sure why it’s doing what it’s doing. Can you change your skin to Estuary or OSMC and see if that changes things. If that doesn’t work I would try reverting to Kodi stock settings, installing the tweaked Plex add-on again, and see how you get on. Instructions on how to do that below.

Kodi default settings

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

Tried Estuary & OSMC skins, still the same behaviour when trying to launch Plex. Rather than risking messing things up reverting to Kodi stock settings etc, I am going to leave it and hope for an update fix in a future Kodi version update.
I can access Plex via my Oppo 203 player or XBox Series X for now.