Plex Kodi Addon

#1

Good evening can anyone explain or offer a solution to the following.

I have a WD Mycloud Running the Plex server whoch streams movies to my LG TV, Tablet, laptop via the plex client without any issues.

However when installing this addon via Kod on my laptop or via OSMC on my rasberry pie 3b+ i get the follwoing issues.

  1. i can see the movies via the plex addon, i select Antman 1080P and it will not play, the player progress bar displays about 10 seconds and if i move it along i get snappits off the the films scenes but it will not play continuously.

I know there is nothing wrong with the file as it plays fine on other devices and through VLC .

If i Transfer the Movie from my plex server onto a external USB HDD and connect this HDD to the Rasberry PI and select the same movie it will play perfectly, could there be something wrong with the plex addon.

#2

It may have be having issues directly connecting to the server and is being routed over the internet. If you post some logs we should be able to see if this is the case. I had this issue and the easiest fix was to go into the settings in my server and tell it not to bother authenticating the IP address of my player.

#3

Thank you, how did you do this

#4

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

#5

Not sure which you were asking about. Logs would be as linked to above. If your asking about the server tweak you would log into your plex server and go to the settings>network>“List of IP addresses and networks that are allowed without auth” and add the IP address of your Pi (you can find this in Kodi under settings>system information).

#6

Hi i have done this i used a mask ip address to allow unsecure access

192.168.1.100/255.255.255.0. now the OSMC plex app shows buffering and is still doing the same playing but only showing a picture no play back

#7

In order to get the video to play in the end i had to drop it to 720p 3mb and this was on Avengers age if altron yet if i play the 1st avengers it plays at the full 1080p bit rate, this is dvd rip whilst the other one is itunes download with drm removed as an experiment

#8

You should only be putting the IP address in.

#9

Yet if i do not use the plex app and play then localy through kodi via hdd they play fine. i have not installed codec licences could this be a problem

#10

The plugin will try to find your server on the local network and if it is able to successfully connect it turns on what it calls ‘direct play’ which is very similar to you just playing it directly in Kodi. If this direct play is disabled or it cannot reach the server for whatever reason then it has your server stream the files over the internet and it then come back to your kodi box over your internet connection. This is why your having to do the transcode and lower the setting. You will need to figure out what the issue is that is causing this.

#11

Ok have had direct play on and off no difference i will not try with just direct stream and see what happens. how do you increas the buffering memory on osmc is there a scrip to auto adjust or to use a temp file on usb storage

#12

tried all i can but still no smooth play i will try purchasing the codecs and add the licence to see if that improves the performance what i still do not get is if it played localy via hdd connected to plex via usb it plays fine. would a usb wifidongle be better suited

#13

If you ssh into your Pi and you type in ping <ip of WD Mycloud> do you get a response? Do you have a wireless guest network it might be connected to or any kind of VPN setup?

#14

yes i get a response when pinging

#15

Would you mind sharing that response and answering the other question.

#16

yes it pinged and no i do not have a wirless guet network set up.

#17

In the Plex add-on settings make sure you have

video>local quality>original
video>allow direct play>(checked)
advanced>allow insecure connections>on same network
advanced>server discovery>(checked)
In you have anything set in manual servers make sure it is correct.

turn on debug logging, reboot twice, play a file in the plex add-on, upload logs

#18

I have my logs but how do i attach them

#19

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

#20

This is the Past bin url http://paste.osmc.io/ezogurexof.xml

This contains me playing movies directly off usb hdd and then me trying to use the plex app for kodi.

https://paste.osmc.tv/guzelucoxu