Plex not loading

Hi all

I have a Vero V and am trying to load up Plex but it just crashes, logs are below:

I’ve tried this: September update killed plex on my Vero 4K+ and it hasn’t worked.

my logs are here:


If your trying to get PKC going and having an issue with that then you would need to reach out to the dev for that one (I assume on Kodi’s forum). If your just talking about the Plex add-on from Kodi’s repository I believe the current status is that is is broken and will not be fixed as Plex themselves are not maintaining it and the person who has been patching it has decided to stop as it was duplicated effort to their fork of the same add-on. The solution is to remove the Plex add-on from the repository and install PlexMod from here…

It has the same interface but it has some additional features over the old Plex4Kodi add-on. You might also be interested in checking out the Composite add-on which is another Kodi interface for Plex.

1 Like

That has worked! Thank you so much!

Also any chance do you know how I can set up a plex server on the same device?

I’ve never tried it myself but this I believe is what your looking for…

Hi Guys,

I use Plex server and client on the same device.
You need to install Server the same way and install the client from repository, then at first run, you need to link them together through the Plex webpate. That’s all.

Thanks. Just for clarity’s sake, are you confirming that the instructions I linked to are still currently the correct ones that someone would follow if they wanted to run the server on their OSMC install?

Hi Darwindesign,

I cannot confirm this since I used the description for Raspberry, but the logic - I assume - is the same. (Server and client on the same device and lin them together via Plex website)

So what I can confirm is that there is a solution to this.


1 Like

Thank you, I’ll give this a go at the weekend.

Really appreciate the support here!